Bug 21831 - Crash at kdm logout
Summary: Crash at kdm logout
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) BSD (Others)
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-20 05:39 UTC by Hasso Tepper
Modified: 2011-07-10 06:47 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Backtrace from core (3.38 KB, text/plain)
2009-05-20 05:39 UTC, Hasso Tepper
no flags Details
xorg.conf (1.80 KB, text/plain)
2009-05-20 05:45 UTC, Hasso Tepper
no flags Details
Xorg.0.log (19.39 KB, text/plain)
2009-05-20 05:45 UTC, Hasso Tepper
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hasso Tepper 2009-05-20 05:39:36 UTC
Created attachment 26034 [details]
Backtrace from core

Xorg server segfaults 100% at kdm (KDE3) logout. No DRM is in use, because with DRM it doesn't just segfault, but locks video hardware up. I'm using Mesa 7.4.2, Xorg server 1.6.1.901, libdrm 2.4.11 and intel driver 2.7.1 on DragonFly BSD platform. Setting EXANoComposite to "true" helps.
Comment 1 Hasso Tepper 2009-05-20 05:45:13 UTC
Created attachment 26035 [details]
xorg.conf
Comment 2 Hasso Tepper 2009-05-20 05:45:59 UTC
Created attachment 26036 [details]
Xorg.0.log
Comment 3 Gordon Jin 2009-06-09 14:28:31 UTC
Please assign to me if this can be reproduced on Linux.
Comment 4 Hasso Tepper 2009-06-15 02:36:31 UTC
This looks awfully the same:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=524287

It's also mentioned in there by Gentoo user -
http://lists.freedesktop.org/archives/xorg/2009-June/045878.html

I'm not 100% sure about this though, but also looks the same:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/348436

Isn't this enough? ;)
Comment 5 Toralf Förster 2009-11-07 02:35:31 UTC
Issue solved w/ x11-drivers/xf86-video-intel-2.9.1 (and
x11-base/xorg-server-1.6.4)
Comment 6 Chris Wilson 2011-07-10 06:47:57 UTC
It is unhelpful to keep these bugs open on known buggy versions of the drivers simply because the infrastructure to test fixes is lacking. Hopefully the situation will improve in the near future and we will be able to start work again on an updated userspace.


bug/show.html.tmpl processed on May 29, 2016 at 09:34:24.
(provided by the Example extension).