Bug 22320 - Not reporting the correct stream direction in Empathy calls
Summary: Not reporting the correct stream direction in Empathy calls
Status: NEW
Alias: None
Product: Telepathy
Classification: Unclassified
Component: gabble (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-16 11:12 UTC by Jonathan Tellier
Modified: 2009-08-19 08:55 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
The gabble log from the side which is actually sending video. (203.71 KB, text/x-log)
2009-06-16 11:12 UTC, Jonathan Tellier
Details
The gabble log from the side which nevers sends video but reporting that it is. (76.96 KB, text/x-log)
2009-06-16 11:13 UTC, Jonathan Tellier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Tellier 2009-06-16 11:12:58 UTC
Created attachment 26862 [details]
The gabble log from the side which is actually sending video.

When doing an audio call in Empathy, if side A starts sending video, it is told that side B is also sending video even though it is not.

See logs for details.
Comment 1 Jonathan Tellier 2009-06-16 11:13:59 UTC
Created attachment 26863 [details]
The gabble log from the side which nevers sends video but reporting that it is.
Comment 2 Will Thompson 2009-06-16 11:16:19 UTC
I think the responder should be changing the stream's senders before accepting.
Comment 3 Will Thompson 2009-08-19 08:55:24 UTC
I just found this comment in _emit_new_stream:

  /* all of the streams are bidirectional from farsight's point of view, it's
   * just in the signalling they change */

Maybe this is secretly the cause.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.