Bug 22626 - [GM965] kernel 2.6.30 /dev/agpgart does not work built in, only as module
Summary: [GM965] kernel 2.6.30 /dev/agpgart does not work built in, only as module
Status: CLOSED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Wang Zhenyu
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-05 15:47 UTC by Mad
Modified: 2017-07-24 23:09 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (1.90 KB, application/octet-stream)
2009-07-05 16:00 UTC, Mad
no flags Details

Description Mad 2009-07-05 15:47:30 UTC
CONFIG_AGP_INTEL built into the kernel caused my Xorg to crash. Once I compile it as a module, it works.

XOrg log attached.


Laptop: HP 6910p
Chipset GM965
Gentoo amd64
gcc 4.4.0
kernel 2.6.30-r2
Xorg 1.5.3
mesa 7.3
libdrm 4.5
Comment 1 Mad 2009-07-05 16:00:04 UTC
Created attachment 27403 [details]
xorg.conf
Comment 2 Mad 2009-07-06 14:52:03 UTC
I was pretty sure I explicitly added my xorg.0.log.old file to my bugreport. I just noticed that it is not listed in the attachment list - and ofcourse I do  not have the logfile anymore.

*grrrr*


Excuse me for the lacking logfile. I remember it says something about not being able to open/access /dev/agpgart because of 'Invalid arguments', and then kernel memory manager failing to allocate memory.

For now I already updated my xorg, mesa and video driver to newer versions because of other problems, which still persist. But more about that in a different bugreport...
Comment 3 Wang Zhenyu 2009-07-07 18:08:44 UTC
That's weird, could you attach dmesg with intel_agp built in and as module?
Comment 4 Wang Zhenyu 2009-08-18 21:58:21 UTC
No problem with built-in agp/intel_agp. 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.