Bug 23145 - dbus-daemon segfault as user with nvidia drivers
Summary: dbus-daemon segfault as user with nvidia drivers
Status: RESOLVED NOTOURBUG
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: 1.2.x
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Havoc Pennington
QA Contact: John (J5) Palmieri
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-05 01:29 UTC by Francesc Ortiz
Modified: 2009-08-05 07:51 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Francesc Ortiz 2009-08-05 01:29:35 UTC
Suddently I cannot use dbus anymore as regular user id if use nvidia drivers, because dbus-daemon gives a segmentation fault.

in dmesg i get this:

dbus-daemon[25832]: segfault at 6ff325e0 ip b7ef930c sp bfd74a10 error 4 in libGL.so.185.18.31[b7ed2000+80000]

I couldn't find any clue of what can be wrong checking on the internet.

What surprises me more is that the segfault only appears as regular user.
Comment 1 Thiago Macieira 2009-08-05 04:04:11 UTC
dbus-daemon doesn't link to libGL, directly or indirectly.

How did you manage to cause libGL to crash dbus-daemon?
Comment 2 Francesc Ortiz 2009-08-05 06:33:00 UTC
I wish I knew. I use the standard dbus-core package in Arch Linux, no custom modifications.

This is the configure command it uses to compile:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
  	      --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
              --with-system-pid-file=/var/run/dbus.pid \
	      --enable-inotify --disable-dnotify \
              --disable-verbose-mode --disable-static \
	      --disable-tests --disable-asserts --without-x
Comment 3 Thiago Macieira 2009-08-05 06:44:53 UTC
Sorry, please take this to Arch Linux. Either they have some modifications to D-Bus to make it link to libGL or they have system modifications to make it load that (LD_PRELOAD or /etc/ld.so.preload).

In any case, this is not a D-Bus bug.
Comment 4 Thiago Macieira 2009-08-05 06:48:18 UTC
This information may be of use: for security reasons, dbus-daemon is compiled with -fPIE and linked with -pie (Position Independent Executable).

However, the NVidia OpenGL libraries are *not* position independent. They have relocations in the .text section. That could be the reason why it crashes: maybe position-independent executables cannot link to position-dependent libraries.
Comment 5 Francesc Ortiz 2009-08-05 07:51:22 UTC
LD_PRELOAD was the cause. I had 'export LD_PRELOAD=/usr/lib/libGL.so.1' in my .bashrc to fix a bug when switching flash web content to fullscreen.

Thank you for your help.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.