Bug 23186 - [i915]many cases of rendercheck failed due to BGRA formats support added
[i915]many cases of rendercheck failed due to BGRA formats support added
Status: VERIFIED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
git
Other Linux (All)
: medium normal
Assigned To: Chris Wilson
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-07 00:22 UTC by zhao jian
Modified: 2010-05-24 01:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.0.log (22.61 KB, text/plain)
2009-08-07 00:22 UTC, zhao jian
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description zhao jian 2009-08-07 00:22:14 UTC
Created attachment 28414 [details]
xorg.0.log

System Environment:
--------------------------
Arch    i386
Platform        945GM
Libdrm:		(master)4507863058a10d00c982975daf396f83caee0fe2
Mesa:		(master)ac3de85eb6af680f2884194b40ada7b3e1edda8a
Xserver:		(master)95b678e6dc41f2524ada4eb11289687fafce7588
Xf86_video_intel:	(master)f4e4c1a8544e264c5a1da02f4e7990a1beecf71e
Kernel:       (drm-intel-next)0c2e39525b3b53a97a0202c5f35058147e53977e

Bug detailed description:
-------------------------
Some rendercheck cases(fill,blend,repeat,triangles) failed because of adding support of render BGRA formats now, which used to be not supported. It also fails on G45. 


Reproduce steps:
----------------
1.xinit&
2. run rendercheck -t fill
Comment 1 zhao jian 2009-09-25 00:47:17 UTC
With commit ce1fe8ddb4a4dbe6cfd909e5b1b73b459d742bec in xserver master branch, it disables b8r8g8x8 in depth 24. rendercheck works well with (fill, repeat, triangles) now. But blend still fails. 

commit ce1fe8ddb4a4dbe6cfd909e5b1b73b459d742bec
Author: Michel D?nzer <daenzer@vmware.com>
Date:   Wed Sep 23 13:10:05 2009 +0200

    render: Don't add b8g8r8x8 format for depth 24.

    The components are required to be packed in the bottom of the pixel, so this
    format can't fit in depth 24.

    Also fix up a comment for the addition of BGRA formats.
Comment 2 Michel Dänzer 2009-09-25 16:53:06 UTC
(In reply to comment #1)
> With commit ce1fe8ddb4a4dbe6cfd909e5b1b73b459d742bec in xserver master branch,
> it disables b8r8g8x8 in depth 24. rendercheck works well with (fill, repeat,
> triangles) now. But blend still fails.

Do you have rendercheck logs for the blend failures? Are the failures produced by hardware or software rendering? If the latter, you may also want to try a newer pixman version.
Comment 3 Chris Wilson 2009-09-26 18:33:59 UTC
The issue lies with pixman. I've ported rendercheck into the pixman test suite and Soeren has begun fixing the failing cases, so the bug is in progress. ;-)
Comment 4 Michel Dänzer 2009-10-26 08:24:18 UTC
Eric, why did you reassign this to me? Reassigning per comment #3.
Comment 5 Søren Sandmann Pedersen 2009-12-02 05:21:38 UTC
With pixman 0.16.2 or newer, do you still see these problems?

Thanks,
Comment 6 zhao jian 2010-01-05 19:41:02 UTC
(In reply to comment #5)
> With pixman 0.16.2 or newer, do you still see these problems?
> Thanks,

Yes, we tested with pixman always updated, now it is 0.17.1 and blend still fails. 
Comment 7 Gordon Jin 2010-01-10 18:37:47 UTC
reopening
Comment 8 Søren Sandmann Pedersen 2010-01-21 06:31:50 UTC
On the nouveau driver, which uses pixman to render into a shadow framebuffer, "rendercheck -t blend" passes without issue, so any further bugs here must be in the Intel driver.

Comment 9 Carl Worth 2010-02-17 14:54:16 UTC
Chris might have some good ideas on this one.

(And, Chris! It's not a bug with strange corruption!)

-Carl
Comment 10 Chris Wilson 2010-05-14 17:21:12 UTC
Had a good long battle with the driver and rendercheck, and I think I have corrected all the bugs I've gradually introduced since the reduction in signal-to-noise in rendercheck from the additional formats.

In short rendercheck is now much happier on i915, and I believe this should equally extend to i830 and i965. Now to check that I have not just caused everything to fallback to software...
Comment 11 Chris Wilson 2010-05-15 02:39:19 UTC
rendercheck passed here.
Comment 12 zhao jian 2010-05-24 01:11:17 UTC
Yes, with the newest code, it now passed on both Pinetrail, G45 and Piketon. So verified.