Bug 23288 - The at-spi2-core component depends on GTK+
Summary: The at-spi2-core component depends on GTK+
Status: RESOLVED FIXED
Alias: None
Product: at-spi2
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Mark Doffman
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-13 07:50 UTC by Marcin Łyko
Modified: 2010-01-14 03:52 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Marcin Łyko 2009-08-13 07:50:06 UTC
The at-spi2-core component uses some GDK stuff, what makes it dependent on GTK+. This is a serious bug sine the at-spi2-core should be GTK+/Qt independent as far as I understand it.
Comment 1 Mark Doffman 2010-01-14 03:52:10 UTC
This has been remedied in commit 0ab59218b5a070632bbc963
and a registry-daemon only dependent on X-lib is therefore available
in release 0.1.5.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.