Bug 23334 - 2D Acceleration not working on RV620/HD3470
Summary: 2D Acceleration not working on RV620/HD3470
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
Depends on:
Reported: 2009-08-15 16:57 UTC by Maximilian Engelhardt
Modified: 2010-10-21 08:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

output of dmesg (27.58 KB, text/plain)
2009-08-15 16:58 UTC, Maximilian Engelhardt
no flags Details
output of lspci (1.81 KB, text/plain)
2009-08-15 16:58 UTC, Maximilian Engelhardt
no flags Details
Xorg.0.log (49.26 KB, patch)
2009-08-15 16:58 UTC, Maximilian Engelhardt
no flags Details | Splinter Review
xorg.conf (844 bytes, text/plain)
2009-08-15 16:59 UTC, Maximilian Engelhardt
no flags Details
screenshot of kdm login (449.12 KB, image/png)
2009-08-15 17:01 UTC, Maximilian Engelhardt
no flags Details
screenshot of X with a single xterm (766.67 KB, image/png)
2009-08-15 17:03 UTC, Maximilian Engelhardt
no flags Details

Description Maximilian Engelhardt 2009-08-15 16:57:31 UTC
I can't get 2D Acceleration (EXA and XV) to work on my Radeon Card.
I'm running a 2.6.31-rc6 kernel with xserver 1.4.2 (from debian testing) and radeon driver from today's git.

When I start kdm I only get a black screen with a small horizontal bar consisting of lots of colored pixels as mouse cursor.
I also tried starting a single xterm. There the xterm is visible, but the terminal output overlaps when the terminal starts scrolling. Also the background is black where I think should be the default X pattern.

I tried taking some screen shots but they all look totally different than the output on my monitor.

When I set 'Option "DRI" "off"' in the xorg.conf everything is as it should be and I didn't notice any problems (except it's not accelerated).

The card is a Sapphire Radeon HD3470 sitting in the PCIexpress slot in my desktop PC.

I'll attach some logs and screen shots.
Comment 1 Maximilian Engelhardt 2009-08-15 16:58:08 UTC
Created attachment 28656 [details]
output of dmesg
Comment 2 Maximilian Engelhardt 2009-08-15 16:58:40 UTC
Created attachment 28657 [details]
output of lspci
Comment 3 Maximilian Engelhardt 2009-08-15 16:58:55 UTC
Created attachment 28658 [details] [review]
Comment 4 Maximilian Engelhardt 2009-08-15 16:59:09 UTC
Created attachment 28659 [details]
Comment 5 Maximilian Engelhardt 2009-08-15 17:01:49 UTC
Created attachment 28660 [details]
screenshot of kdm login

Note: the actual output on my screen is black background with only a small horizontal bar as the mouse cursor
Comment 6 Maximilian Engelhardt 2009-08-15 17:03:37 UTC
Created attachment 28661 [details]
screenshot of X with a single xterm

Again the actual output of my screen is different than the screen shot.
Comment 7 Michel Dänzer 2009-08-22 16:14:38 UTC
Does it also happen with a newer X server, e.g. 1.6.x from Debian sid?
Comment 8 Maximilian Engelhardt 2009-08-24 05:00:30 UTC
I tried with a Ubuntu 9.10 (Karmic Koala) Alpha 4 live CD and it's the same problem there. I guess this should be a recent enough X server.
Comment 9 Maximilian Engelhardt 2009-09-02 12:44:31 UTC
Today I tried the card in a friends PC and there it does work without any problems. So I guess the problem is the combination of my Motherboard and the GPU.

My Motherboard is an Asrock P4Dual-880Pro which has an AGP and a PCIe Slot. The AGP Slot is empty and the GPU is in the PCIe slot.

If you need any addition information about it feel free to ask.
Comment 10 Alex Deucher 2009-09-11 10:51:27 UTC
Maximilian mentioned on IRC that his slot was only x4.  Perhaps that's the issue.  You can try forcing a lower number of pcie lanes with:
Option "ForceLowPowerMode" "TRUE"
in the device section of your config.
Comment 11 Maximilian Engelhardt 2009-09-11 11:16:04 UTC
I tried with this option but it didn't change anything.
Comment 12 Alex Deucher 2010-10-19 17:42:23 UTC
Is this still an issue with kms or a newer version of the driver?
Comment 13 Maximilian Engelhardt 2010-10-21 03:42:32 UTC
I can't test anymore since I no longer have this hardware combination.
Feel free to close the bug.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.