Bug 23660 - [RV350] X.org freeze unless XAA used
[RV350] X.org freeze unless XAA used
Status: RESOLVED NOTOURBUG
Product: xorg
Classification: Unclassified
Component: Driver/Radeon
7.4 (2008.09)
x86 (IA32) Linux (All)
: medium normal
Assigned To: xf86-video-ati maintainers
Xorg Project Team
: regression
Depends on:
Blocks: 32107
  Show dependency treegraph
 
Reported: 2009-09-02 17:30 UTC by Bryce Harrington
Modified: 2011-10-11 11:35 UTC (History)
4 users (show)

See Also:


Attachments
Xorg.0.log (81.61 KB, text/plain)
2009-09-02 17:30 UTC, Bryce Harrington
no flags Details
Xorg.0.log - 1:6.12.99+git20090902.794ae743-0ubuntu0tormod (80.00 KB, patch)
2009-09-03 09:34 UTC, raphael
no flags Details | Splinter Review
dmesg output (21.30 KB, text/plain)
2010-03-28 02:57 UTC, SpOeK@DistroBit.Net
no flags Details
Xorg output (52.86 KB, text/plain)
2010-03-28 02:58 UTC, SpOeK@DistroBit.Net
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2009-09-02 17:30:06 UTC
Created attachment 29128 [details]
Xorg.0.log

Forwarding this bug from Ubuntu reporter MyName:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/349229

[Problem]
X freezes after about 1-2 minutes unless XAA used.  The system has 64MB so XAA is not getting forced on by default.

This is a regression from Intrepid to Jaunty, verified as still affecting Karmic, and tested against git up to commit f39cafc5 via xorg-edgers, and by another user with the same hardware up to commit 20090805.bd03977e.

[Original Description]
Hi,

I did a clean Jaunty install. Now I have the problem that the System freeze randomly. I cant't reproduce the freeze. It happens randomly 1-2 times a day at browsing with firefox, searching with Gnome-Do or nautilus or at idling.

The Keyboard and mouse stop working too. REISUB doesn't work, have to push Powerbutton to power-off system. 

Intrepid works fine, there was no problem with freezes.

Version 1:6.12.99+git20090629.f39cafc5-0ubuntu6 was tested and found to freeze the system within 1-2 minutes.

I turned on Compiz and the System is freezing after a few minutes. Tried the workaround setting AGPmode to 1 / 2 / 4, doesn't help.

https://wiki.ubuntu.com/X/Quirks#ATI%20AGP%20Mode%20Quirk
<snip>
Typical Symptoms:

    * X hangs (pointer still moves) or shows corruption:
</snip>

Please see initial post. Mouse/keyboard freeze too.


-------------------
The last entry in the xorg.0.log is:

exaCopyDirty: Pending damage region empty!


Some Information:
-------------------
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
-------------------
xserver-xorg-video-ati:
  Installiert: 1:6.12.1-0ubuntu1
  Kandidat: 1:6.12.1-0ubuntu1
  Versions-Tabelle:
 *** 1:6.12.1-0ubuntu1 0
        500 http://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status
-------------------
Description:	Ubuntu jaunty (development branch)
Release:	9.04

With full updates
-------------------
Linux PC 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:23 UTC 2009 i686 GNU/Linux
-------------------
Comment 1 Alex Deucher 2009-09-02 22:48:08 UTC
please try with the latest git from master.  make sure you have:
794ae743c305331741e7cf45dd71c755fe325ed5
Comment 2 Bryce Harrington 2009-09-03 01:23:28 UTC
A Ubuntu package of 794ae743 can be found in this PPA for testing:

https://edge.launchpad.net/~xorg-edgers/+archive/ppa
 +  xserver-xorg-video-ati - 1:6.12.99+git20090902.794ae743-0ubuntu0tormod 

Comment 3 raphael 2009-09-03 09:29:52 UTC
Hi,

I tested the suggested package from xorg-edgers PPA:

xserver-xorg-video-ati - 1:6.12.99+git20090902.794ae743-0ubuntu0tormod

System freezes after seconds.

---------

After restart I saved the Xorg.log. I think the log process was interrupted by the freeze. The saved Xorg.log is NOT complete, but I will attach it too.
Comment 4 raphael 2009-09-03 09:34:08 UTC
Created attachment 29179 [details] [review]
Xorg.0.log - 1:6.12.99+git20090902.794ae743-0ubuntu0tormod
Comment 5 Alex Deucher 2009-09-03 09:47:10 UTC
Do any of the following options help?
Option "EXANoComposite"
Option "EXANoUploadToScreen"
Option "BusType" "PCI"
Comment 6 Gytis Raciukaitis 2009-09-03 10:24:39 UTC
hi,

following the recommendations on the other defect on freedesktop I have force the card into the PCI mode using the radeon driver option radeon.agpmode=-1 in karmic. 

After that I'm running with no problems for one week. I guess this should work with non KMS setup as well. 

Do we really need an AGP Quirk ? 
Comment 7 Gytis Raciukaitis 2009-09-03 10:35:18 UTC
I'm using the latest from https://launchpad.net/~ubuntu-x-swat/+archive/kms

xserver-xorg-video-ati - 1:6.12.99+git20090805.bd03977e-0ubuntu2
Comment 8 Alex Deucher 2009-09-03 10:35:56 UTC
(In reply to comment #6)
> hi,
> 
> following the recommendations on the other defect on freedesktop I have force
> the card into the PCI mode using the radeon driver option radeon.agpmode=-1 in
> karmic. 
> 
> After that I'm running with no problems for one week. I guess this should work
> with non KMS setup as well. 
> 
> Do we really need an AGP Quirk ? 
> 

Please file a different bug as your bug may not be related to this one.
Comment 9 mrsteven 2009-10-11 06:01:10 UTC
Same here with all radeon driver releases that support render accelleration with EXA (latest I've tested is xf86-video-ati-6.12.4). The system freezes completely, even the music stops to play.

My current setup on gentoo:
x11-base/xorg-server-1.6.3.901-r2
x11-drivers/xf86-video-ati
media-libs/mesa-7.5.1

When I switch to AccelMethod "exa" it works fine again, but with EXA the system freezes, usually when I'm scrolling a website in firefox.
Comment 10 mrsteven 2009-10-11 06:02:55 UTC
Forgot to mention: card is a Radeon Mobility 9600. Here's my lspci:

00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 21)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 21)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
02:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:01.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ac)
02:01.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 04)
02:02.0 Network controller: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)
Comment 11 mrsteven 2009-10-11 08:55:33 UTC
(In reply to comment #9)
> When I switch to AccelMethod "exa" it works fine again, but with EXA the system
> freezes, usually when I'm scrolling a website in firefox.
> 

Switching to AccelMethod "xaa", I mean... Sorry for the spam!
Comment 12 Michel Dänzer 2009-11-05 06:46:27 UTC
The most interesting information right now would be the answers to the questions from comment #5.
Comment 13 chromakode 2009-11-09 21:44:19 UTC
(In reply to comment #12)
> The most interesting information right now would be the answers to the
> questions from comment #5.
> 

I have also been affected by this bug since Ubuntu Jaunty (just found this bug last night). I was disappointed to find that the hard freezing still occurs under Karmic. Freezing happens within a few minutes with compiz running; it happens in a matter of days without compiz running (usually when moving a window, alt-tabbing, or opening a menu). Metacity with composite running and AccelMethod set to XAA seems to be doing fine so far.

I would like to do whatever I can to help get this fixed.

Michel, please let me know what to try. Would you like every combination of the options you posted tested? I am also available on FreeNode as 'chromakode' if you'd have things you'd like me to test.

Thank you,
-C

System Info:
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

chromakode@druid:~$ apt-cache policy xserver-xorg-video-ati
xserver-xorg-video-ati:
  Installed: 1:6.12.99+git20090929.7968e1fb-0ubuntu1
  Candidate: 1:6.12.99+git20090929.7968e1fb-0ubuntu1
  Version table:
 *** 1:6.12.99+git20090929.7968e1fb-0ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/main Packages
        100 /var/lib/dpkg/status

chromakode@druid:~$ uname -a
Linux druid 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux
Comment 14 mrsteven 2010-02-10 15:08:11 UTC
(In reply to comment #5)
> Option "BusType" "PCI"

That seems to do the trick. Haven't tried the other options yet, but with this EXA is stable, even with AIGLX and Compositing from KDE 4. Without the BusType Option the system freezes quite quickly.

Packages are as follows:



$ emerge -pv xf86-video-ati mesa libdrm vanilla-sources xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/libdrm-2.4.15  USE="-debug" 0 kB
[ebuild   R   ] sys-kernel/vanilla-sources-2.6.32.8  USE="symlink -build" 0 kB
[ebuild   R   ] media-libs/mesa-7.5.2  USE="nptl xcb -debug -motif -pic" VIDEO_CARDS="radeon -intel -mach64 -mga -none -r128 -radeonhd -s3virge -savage -sis (-sunffb) -tdfx -trident -via" 0 kB
[ebuild   R   ] x11-base/xorg-server-1.6.5-r1  USE="hal nptl sdl xorg -debug -dmx -ipv6 -kdrive -minimal -tslib" 0 kB
[ebuild   R   ] x11-drivers/xf86-video-ati-6.12.4-r1  USE="-debug" 0 kB

Comment 15 Alex Deucher 2010-02-10 15:31:05 UTC
(In reply to comment #14)
> (In reply to comment #5)
> > Option "BusType" "PCI"
> 
> That seems to do the trick. Haven't tried the other options yet, but with this
> EXA is stable, even with AIGLX and Compositing from KDE 4. Without the BusType
> Option the system freezes quite quickly.

Can you try changing the AGPMode?  Remove the BusType option and try:
Option "AGPMode" "X"
where X = 1 or 2 or 4 or 8
Comment 16 SpOeK@DistroBit.Net 2010-03-27 08:50:44 UTC
I may have the same problem here.
If I use XAA, everything works fine but Xorg recommends me to use EXA over XAA.
If I use EXA, the graphical login appears corrupted, specially the fonts. If I log in, the system freezes in a few seconds. Even the SysRq combo doesn't work.

I've tried the next:
With "BusType" "PCI" I get "(WW) RADEON(0): Option "BusType" is not used".
Options "EXANoUploadToScreen" and "EXANoDownloadFromScreen" are useless, the freeze continues.
Option "EXANoComposite" gives me a working system but, in exchange, it seems to make X a very cpu hungry process.

My GPU is an "ATI R300 AD [Radeon 9500 Pro]". I'm on a Gentoo box using the git version of the graphic stack through the x11 overlay.

Please, feel free to ask for more information or if you want me to try a patch.
Comment 17 Alex Deucher 2010-03-27 10:01:29 UTC
(In reply to comment #16)
> I may have the same problem here.
> If I use XAA, everything works fine but Xorg recommends me to use EXA over XAA.
> If I use EXA, the graphical login appears corrupted, specially the fonts. If I
> log in, the system freezes in a few seconds. Even the SysRq combo doesn't work.
> 
> I've tried the next:
> With "BusType" "PCI" I get "(WW) RADEON(0): Option "BusType" is not used".
> Options "EXANoUploadToScreen" and "EXANoDownloadFromScreen" are useless, the
> freeze continues.
> Option "EXANoComposite" gives me a working system but, in exchange, it seems to
> make X a very cpu hungry process.
> 
> My GPU is an "ATI R300 AD [Radeon 9500 Pro]". I'm on a Gentoo box using the git
> version of the graphic stack through the x11 overlay.
> 
> Please, feel free to ask for more information or if you want me to try a patch.
> 

Can you attach your xorg log and dmesg?  It sounds like you may be using KMS, in which case, there is only EXA support as XAA doesn't work with kms.
Comment 18 SpOeK@DistroBit.Net 2010-03-28 02:57:18 UTC
Created attachment 34514 [details]
dmesg output

dmesg output as requested.
Comment 19 SpOeK@DistroBit.Net 2010-03-28 02:58:46 UTC
Created attachment 34515 [details]
Xorg output

Xorg.0.log file.
Comment 20 SpOeK@DistroBit.Net 2010-03-28 03:09:07 UTC
(In reply to comment #17)
> Can you attach your xorg log and dmesg?  It sounds like you may be using KMS,
> in which case, there is only EXA support as XAA doesn't work with kms.
> 
I'm sorry, I forgot to tell that, indeed, I'm trying to use KMS. As you can see in dmesg, my kernel is from git also: 2.6.33-rc8.

I can attach my .config if you wish but these are the related parameters to radeon in it:
CONFIG_DRM_RADEON=m
CONFIG_DRM_RADEON_KMS=y
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_FB=y
# CONFIG_FB_RADEON is not set

My last build from git was in March 5th but I can catch up if necessary, kernel included.
Comment 21 Michel Dänzer 2010-03-28 06:33:38 UTC
(In reply to comment #16)
> Option "EXANoComposite" gives me a working system but, in exchange, it seems to
> make X a very cpu hungry process.

I've found that drm-radeon-testing commit 924788672f9c802a4c8e6bc8d88fbc2c9b2e3089 ('drm/radeon/bo: add some fallback placements for VRAM only objects.') can result in GPU lockups due to the 3D engine trying to access unbound GTT memory, and the new GPU reset code can hardlock the system when trying to recover from the lockup. If your kernel has that commit, try reverting it.

Note that this report was about non-KMS so your problem should be tracked elsewhere.
Comment 22 SpOeK@DistroBit.Net 2010-03-28 09:20:19 UTC
(In reply to comment #21)
> (In reply to comment #16)
> > Option "EXANoComposite" gives me a working system but, in exchange, it seems to
> > make X a very cpu hungry process.
> 
> I've found that drm-radeon-testing commit
> 924788672f9c802a4c8e6bc8d88fbc2c9b2e3089 ('drm/radeon/bo: add some fallback
> placements for VRAM only objects.') can result in GPU lockups due to the 3D
> engine trying to access unbound GTT memory, and the new GPU reset code can
> hardlock the system when trying to recover from the lockup. If your kernel has
> that commit, try reverting it.
> 
> Note that this report was about non-KMS so your problem should be tracked
> elsewhere.
> 

My kernel doesn't have that commit :(
I've followed your recommendation and I've filed a new bug report: #27355 (https://bugs.freedesktop.org/show_bug.cgi?id=27355)
Comment 23 mrsteven 2010-07-11 16:15:04 UTC
I did not have the problem with the kernel 2.6.33 series (that I used for at least 2 months while writing my thesis), KMS and xf86-video-ati-6.13.0. Today I updated to Kernel 2.6.34 and I got the same freeze again. The system runs with radeon.agpmode=-1 right now, let's see if it crashes again.

Anyway, I think in this case it's more of a kernel bug...
Comment 24 Jeremy Huddleston 2011-10-11 11:35:23 UTC
No response in a while.  Closing based on recent comments.