Bug 24266 - input text corruption
Summary: input text corruption
Status: VERIFIED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) FreeBSD
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-01 14:28 UTC by Andriy Gapon
Modified: 2009-10-19 23:51 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
screenshot fragment that demonstrates the corruption (6.96 KB, image/png)
2009-10-01 14:28 UTC, Andriy Gapon
Details
corruption from vertical cursor movement (2.26 KB, image/png)
2009-10-18 00:16 UTC, Andriy Gapon
Details
non-text corruption (2.21 KB, image/png)
2009-10-18 01:17 UTC, Andriy Gapon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andriy Gapon 2009-10-01 14:28:14 UTC
Created attachment 29986 [details]
screenshot fragment that demonstrates the corruption

Environment:
- latest mesa driver from git
- latest libdrm from git
- latest xf86-video-ati
- ATI Radeon HD 3200 Graphics (ChipID = 0x9610)
- DRI, AIGLX, EXA enabled
- KDE4 with OpenGL desktop effects enabled

Corruption happens only with text and only when the text is put in.
The corruption happens while simply entering/editing text and also while moving cursor through the text.

I believe that this might be a known issue.
I am reporting it for the sake of proper tracking.

I am attaching a screenshot taken after moving cursor though some text in input box of google search (in firefox).
Comment 1 Alex Deucher 2009-10-15 08:44:07 UTC
fixed:
22a0029a68cf6a17e5d799c7d8eb8a699ccdeabb
Comment 2 Andriy Gapon 2009-10-15 11:01:11 UTC
This will go to 'master' too, of course?
Comment 3 Alex Deucher 2009-10-15 11:09:17 UTC
(In reply to comment #2)
> This will go to 'master' too, of course?
> 

7.6 branch gets merged into master regularly, so yes.
Comment 4 Andriy Gapon 2009-10-16 01:33:03 UTC
Thank you for fixing this!
Everything is perfect now.
Comment 5 Andriy Gapon 2009-10-18 00:16:11 UTC
Created attachment 30513 [details]
corruption from vertical cursor movement

I probably was too fast to mark this bug verified.
First, the change is not yet merged to master (I did a local cherry-pick to check it).
Second, it looks like still get some corruptions although they are much rarer and much harder to reproduce. Now, they are mostly happen from vertical cursor movement, e.g. in thunderbird's mail composition window.

The previous testcase, fast horizontal cursor movement, doesn't produce any corruption anymore.
Comment 6 Andriy Gapon 2009-10-18 00:16:54 UTC
Given comment #5 I am re-opening this bug.
Comment 7 Andriy Gapon 2009-10-18 01:17:56 UTC
Created attachment 30514 [details]
non-text corruption

I am not sure if this kind of corruption is related to this bug.
I see this with thunderbird while opening/downloading a rather big messages.
Comment 8 Alex Deucher 2009-10-19 08:17:58 UTC
Should be fixed now:
8123180ea649540fb7319bc79ad77dca0d5d68cd
Comment 9 Andriy Gapon 2009-10-19 23:51:06 UTC
Tested and verified with git master.
This time I made sure to try to reproduce the symptoms in every way I could imagine.
Big thanks to all who did this!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.