Bug 24846 - [i915 bisected] OGLC/texlod regressed
[i915 bisected] OGLC/texlod regressed
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
Other Linux (All)
: medium normal
Assigned To: Eric Anholt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-01 17:17 UTC by Shuang He
Modified: 2010-06-05 19:35 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shuang He 2009-11-01 17:17:53 UTC
System Environment:
--------------------------
Kernel  (drm-intel-next)a83a4400415893d2599a256f6842ac4d871dffd7
Libdrm  (master)b0b96636dbf93445dd532b09b21fa4fc5ce6bdc7
Mesa    (master)1cc16e1b831cef8e1573cc998cee3e55179bb830
Xserver         (master)d30637339963950910e5f5fb755b8465ac7dddb4
Xf86_video_intel        (master)10946118dd3a63f1375a1bfde0b2f0542a93c1c2




Bug detailed description:
-------------------------
This issue happens on 945GM
OGLC cases lodbias and texlod regressed due to following commit:
commit f8f40b53a6a4551630e25bfd7f6e12334bb0f3f8
Author: Eric Anholt <eric@anholt.net>
Date:   Thu Oct 29 11:52:28 2009 -0700

    i915: Implement min/max LOD clamping with the hardware.

    This gets us expected behavior for clamping between mipmap levels, and
    avoids relayout of textures for doing clamping.

    Fixes piglit lodclamp-between.
Comment 1 Shuang He 2010-01-05 17:29:03 UTC
This regression get fixed by following commit:
commit b434a816d7a4b298e16a8b51b54e5a2d5ea28da8
Author: Eric Anholt <eric@anholt.net>
Date:   Tue Dec 29 15:55:34 2009 -0800

    i915: Use _MaxLevel on principle in texture setup.

    It was OK before because we proceed to clamp the value to hardware
    limits, but given that other use of MaxLevel has been a trap, let's
    avoid it.
Comment 2 Shuang He 2010-01-05 17:30:24 UTC
verified on 945GM with:
Libdrm:         (master)c5c503b519777fb9ebbaa22681a1ed81717c1d71
Mesa:           (master)1f9aa38f4e2be47229d92be2c1189c2b8d9c7133
Xserver:                (master)13c8bd3fde3b0831921e59f84936022a16379d63
Xf86_video_intel:               (master)091035146463bf1aa6674bff6947d04fc620c18f
Kernel:       (drm-intel-next)cf74ecbbff3e3b45bae61d28d2220f74d853e2f0
Comment 3 Shuang He 2010-01-07 17:38:51 UTC
Sorry that I mis-check the texlod.c case, it still fails.
lodbias.c is passed
Comment 4 Eric Anholt 2010-03-26 12:38:03 UTC
We've got open-source tests for texture LOD functionality that are passing, so I'm not too concerned about a failure in the closed testsuite.  We would need to isolate a testcase for inclusion in piglit if we want this bug fixed.
Comment 5 Eric Anholt 2010-06-04 13:29:34 UTC
commit b80a728f8a86cbd1efce9611d822ab73b5baeab9
Author: Eric Anholt <eric@anholt.net>
Date:   Fri Jun 4 13:27:05 2010 -0700

    i915: Clamp minimum lod to maximum texture level too.
    
    Otherwise, we'd run into minlod > maxlod, and the sampler would give
    us the undefined we asked for.
    
    Bug #24846.  Fixes OGLC texlod.c.
Comment 6 Shuang He 2010-06-05 19:35:09 UTC
verified on Pineview with:
Libdrm:		(master)2.4.20-19-g73a42a645201a85ce2fe4fc77754df67e5097fc9
Mesa:		(master)mesa_7_6_1_rc1-8652-g42ebe3dfd9b0803913e0d932909ca5872d937c20
Xserver:		(master)xorg-server-1.8.0-332-g6b4af3b7925978cd79f717761f1b6f33bd8dfbaf
Xf86_video_intel:		(master)2.11.0-151-g6db1e5231b7a0e79611f771d4efea686f7849e04
Kernel:       (for-linus)e3a815fcd38043b8f1bb526123d8ab6ae01deb77