Bug 250 - lbxproxy dies with VSW5 'Xlib3/XCloseDisplay' test
lbxproxy dies with VSW5 'Xlib3/XCloseDisplay' test
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/General
unspecified
SPARC Solaris
: low minor
Assigned To: Alan Coopersmith
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-01 16:06 UTC by Alan Coopersmith
Modified: 2007-01-23 17:32 UTC (History)
0 users

See Also:


Attachments
patch to xc/programs/lbxproxy/di/resource.c (825 bytes, patch)
2004-03-01 16:07 UTC, Alan Coopersmith
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Coopersmith 2004-03-01 16:06:04 UTC
lbxproxy process dies when running VSW5 in Xlib3/XCloseDisplay test, assertion 6.

The cause of the problem is that LookupIDByType() try to access non-existing
client(clients[j] = NULL). The checking code needs to be added to make sure that
LookupIDByType() doesn't search non-existing clients.

(This was originally found and fixed by Derek Wang in Solaris Xsun as Sun bug id
 4416710.  It was also reported as defect #9341 in the old X.org bug db.)
Comment 1 Alan Coopersmith 2004-03-01 16:07:23 UTC
Created attachment 113 [details] [review]
patch to xc/programs/lbxproxy/di/resource.c
Comment 2 Alan Coopersmith 2004-03-01 20:32:00 UTC
Fix committed to XORG-CURRENT branch.