Bug 2527 - Fontconfig confused by Adobe Garamond family
Fontconfig confused by Adobe Garamond family
Status: RESOLVED NOTOURBUG
Product: fontconfig
Classification: Unclassified
Component: library
2.2
x86 (IA32) Linux (All)
: high normal
Assigned To: Keith Packard
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-12 00:53 UTC by Ralph Aichinger
Modified: 2005-02-23 15:02 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Aichinger 2005-02-12 00:53:33 UTC
This is copy&paste from a bugreport originally intended for downstream Debian BTS:
Subject: Large family confuses fontconfig
Package: fontconfig
Version: 2.2.3-4
Severity: normal

*** Please type your report below this line ***
I' ve just bought some nice Adobe fonts with small caps and
oldstyle figures. I tried to install them by putting them
into .fonts in my home directory. The following files were
copied there, all directly from the CD, no conversion or
similar:

AGaramond-Italic.afm
AGaramond-Italic.pfa
AGaramond-ItalicOsF.afm
AGaramond-ItalicOsF.pfa
AGaramond-Regular.afm
AGaramond-Regular.pfa
AGaramond-RegularSC.afm
AGaramond-RegularSC.pfa
AGaramond-Semibold.afm
AGaramond-Semibold.pfa
AGaramond-SemiboldItalic.afm
AGaramond-SemiboldItalic.pfa
AGaramond-SemiboldItalicOsF.afm
AGaramond-SemiboldItalicOsF.pfa
AGaramond-SemiboldSC.afm
AGaramond-SemiboldSC.pfa
AGaramond-Titling.afm
AGaramond-Titling.pfa

fc-list gives me the following:

client21% fc-list | grep Garam | sort
Adobe Garamond:style=Italic
Adobe Garamond:style=Italic Oldstyle Figures
Adobe Garamond:style=Regular
Adobe Garamond:style=Semibold
Adobe Garamond:style=Semibold Italic
Adobe Garamond:style=Semibold Italic Oldstyle Figures
Adobe Garamond:style=Semibold Small Caps & Oldstyle Figures
Adobe Garamond:style=Small Caps & Oldstyle Figures
Adobe Garamond:style=Titling Capitals

but that does not really help me in practice because
I cannot use these fonts. In the font menu of e.g. 
AbiWord I get "Adobe Garamond". If I select the regular
style (no Bold, no Italic) I get "Adobe Garamond:style=Semibold".

If I select italic, I get "Adobe Garamond:style=Semibold Italic Oldstyle
Figures".

I cannot select any other styles in this family. 

I am not even sure this is a bug, or a bug in fontconfig, but 
if it is not a bug, IMHO the documentation could be improved.
If it is a bug somewhere else, please do tell me!

TIA
/ralph


-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (101, 'experimental')
Architecture: i386 (i686)
Kernel: Linux 2.6.9
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages fontconfig depends on:
ii  debconf [debconf-2.0]       1.4.42       Debian configuration management sy
ii  defoma                      0.11.8-0.1   Debian Font Manager -- automatic f
ii  gsfonts-x11                 0.17         Make Ghostscript fonts available t
ii  libc6                       2.3.2.ds1-20 GNU C Library: Shared libraries an
ii  libfontconfig1              2.2.3-4      generic font configuration library
ii  msttcorefonts               1.2          Installer for Microsoft TrueType c
ii  ttf-bitstream-vera          1.10-3       The Bitstream Vera family of free 
ii  ucf                         1.13         Update Configuration File: preserv

-- debconf information:
* fontconfig/rendering_type: Bytecode interpreter (CRT screens)
* fontconfig/subpixel_rendering: false
* fontconfig/enable_bitmaps: false
* fontconfig/enable_autohinter: false
Comment 1 Keith Packard 2005-02-24 10:02:59 UTC
This appears to be largely an application limitation -- applications which
specify only weight/slant values are unable to correctly disambiguate among
several varients not covered by those settings.  I'm not quite sure how to solve
this; application developers seem reluctant to offer the actual style names in
menus, even though they are often localized in the font file.

There is a minor bug demonstrated here which should be fixed in CVS -- mistaking
Semibold for Regular.