Bug 25469 - [RS690] Screen corruption on X [KMS]
Summary: [RS690] Screen corruption on X [KMS]
Status: RESOLVED DUPLICATE of bug 27529
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 7.5 (2009.10)
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: xf86-video-ati maintainers
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-05 20:07 UTC by Todd Merrill
Modified: 2010-05-05 07:48 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot (463.98 KB, image/png)
2009-12-05 20:07 UTC, Todd Merrill
no flags Details
Xorg log (22.41 KB, text/plain)
2009-12-05 20:08 UTC, Todd Merrill
no flags Details
Kernel log (33.29 KB, text/plain)
2009-12-05 20:08 UTC, Todd Merrill
no flags Details
Xorg log (21.85 KB, text/plain)
2009-12-06 21:04 UTC, Todd Merrill
no flags Details
Kernel log (32.66 KB, text/plain)
2009-12-06 21:04 UTC, Todd Merrill
no flags Details
force gart to 32 mb (490 bytes, patch)
2009-12-06 22:59 UTC, Alex Deucher
no flags Details | Splinter Review
Xorg log - post patch (21.85 KB, text/plain)
2009-12-07 07:16 UTC, Todd Merrill
no flags Details
Kernel log - post patch (32.86 KB, text/plain)
2009-12-07 07:16 UTC, Todd Merrill
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Todd Merrill 2009-12-05 20:07:28 UTC
Created attachment 31775 [details]
Screenshot

I am experiencing screen/font corruption in X when using kernel modesetting.  The logs show no signs of trouble.  Userspace modesetting has not given me any problems.

Dave Airlie said that this may be related to sideport memory.  The machine in question is a Gateway LT3103u, which ships with X1270 graphics, making it a M690T.  According to Wikipedia, the M690T features "an optional 16-bit DDR2 side-port memory with maximum 128 MiB."  I believe Gateway has implemented this, as can be seen by the memory chip between the chipset and battery in this image:
http://i340.photobucket.com/albums/o328/Secret_Asian_Man/IMG_6610.jpg

Unfortunately there is no option to disable sideport memory in the BIOS, nor are there any BIOS updates available from Gateway.

I'm using libdrm & xf86-video-ati from git master, along with xserver's server-1.7-branch and mesa's mesa_7.7_branch.  The kernel is 2.6.32 with the	drm-radeon-next repository merged.  I've also encountered this problem with Fedora 11/12 in the past.
Comment 1 Todd Merrill 2009-12-05 20:08:09 UTC
Created attachment 31776 [details]
Xorg log
Comment 2 Todd Merrill 2009-12-05 20:08:32 UTC
Created attachment 31777 [details]
Kernel log
Comment 3 Alex Deucher 2009-12-06 09:00:29 UTC
If it's not a problem with UMS, then it's not likely to be sideport related.
Comment 4 Alex Deucher 2009-12-06 20:10:17 UTC
This bug is likely a partial duplicate of bug 25408.  Can you try the patches on that bug?
Comment 5 Todd Merrill 2009-12-06 21:04:04 UTC
The patches posted in bug 25408 did not do the trick.
Comment 6 Todd Merrill 2009-12-06 21:04:34 UTC
Created attachment 31794 [details]
Xorg log
Comment 7 Todd Merrill 2009-12-06 21:04:51 UTC
Created attachment 31795 [details]
Kernel log
Comment 8 Alex Deucher 2009-12-06 22:59:08 UTC
Created attachment 31800 [details] [review]
force gart to 32 mb

Does this help (on top of the previous 3)?
Comment 9 Todd Merrill 2009-12-07 07:14:12 UTC
I'm afraid not.  Things begin to resemble the original screenshot after a minute or two.
Comment 10 Todd Merrill 2009-12-07 07:16:27 UTC
Created attachment 31814 [details]
Xorg log - post patch
Comment 11 Todd Merrill 2009-12-07 07:16:49 UTC
Created attachment 31815 [details]
Kernel log - post patch
Comment 12 Alex Deucher 2009-12-07 10:02:56 UTC
Are you using a GL compositer (kwin or compiz)?  Does disabling it fix the issues?
Comment 13 Todd Merrill 2009-12-07 10:13:10 UTC
No, I'm not using a compositer.
Comment 14 Todd Merrill 2010-01-16 18:50:19 UTC
I've been able to reproduce this with UMS as well.  It seems to crop up after a few days of use (versus a few minutes with KMS), mostly when using Firefox to view large JPEG images.  Switching to a console and back usually clears up most of the corruption, but once it has occured, it doesn't take long to come back again.  I've had to switch to RadeonHD for stability reasons.
Comment 15 dE 2010-03-31 22:46:24 UTC
+1

On the same chipet and graphs chip, using KMS makes the desktop unusable.
Comment 16 Jason 2010-05-05 07:39:54 UTC
(In reply to comment #15)
> +1
> 
> On the same chipet and graphs chip, using KMS makes the desktop unusable.

Same issue with Ubuntu 10.04. Same machine as well. Sticking with 9.10 for the time being until this is fixed.
Comment 17 Alex Deucher 2010-05-05 07:48:45 UTC
Can you try the patch in bug 27529?

*** This bug has been marked as a duplicate of bug 27529 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.