Bug 25838 - OpenGl app crashes with "No buffer for z buffer"
OpenGl app crashes with "No buffer for z buffer"
Status: RESOLVED DUPLICATE of bug 23532
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300
x86 (IA32) Linux (All)
: medium normal
Assigned To: Default DRI bug account
Depends on:
  Show dependency treegraph
Reported: 2009-12-31 00:01 UTC by Trevor Campbell
Modified: 2009-12-31 05:48 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

Xorg.o.log (93.06 KB, text/plain)
2009-12-31 00:01 UTC, Trevor Campbell

Note You need to log in before you can comment on or make changes to this bug.
Description Trevor Campbell 2009-12-31 00:01:14 UTC
Created attachment 32380 [details]

I am the current maintainer of a java application that uses OpenGL via the JOGL bindings (http://sourceforge.net/projects/fgflightplanner).  This app crashes with the following message in the console when using the latest Radeon driver under Fedora 12:
drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream. See dmesg for more info.

dmesg has the following 2 entries:
[drm:r100_cs_track_check] *ERROR* [drm] No buffer for z buffer !
[drm:radeon_cs_ioctl] *ERROR* Invalid command stream !

If I boot with radeon.modeset=0, the application runs (but not well, always on top of everything)

The application is a mature app and runs well with other drivers (fglrx) and on other platforms.

I am using Fedora 12 with all the latest updates:
$ uname -a
Linux kelpie5.campbell.priv #1 SMP Mon Dec 21 06:24:20 UTC 2009 i686 i686 i386 GNU/Linux
Comment 1 Michel Dänzer 2009-12-31 01:17:09 UTC
This is an issue in the Mesa driver or in the kernel, not in the X driver.
Comment 2 Marc Dietrich 2009-12-31 05:48:51 UTC
probably same as bug 23532. 

*** This bug has been marked as a duplicate of bug 23532 ***