Bug 2587 - Sun Ultra2 kbd driver in xorg
Summary: Sun Ultra2 kbd driver in xorg
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: 6.8.2
Hardware: SPARC Linux (All)
: high normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
: 1722 (view as bug list)
Depends on:
Blocks: 890
  Show dependency treegraph
 
Reported: 2005-02-21 09:53 UTC by Everett Giles
Modified: 2005-07-12 19:28 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Everett Giles 2005-02-21 09:53:31 UTC
I have a Sun Ultra2 running Gentoo Linux with xorg-x11-6.8.2. When I use the
"kbd" driver, my Sun type5 keyboard does not work properly at all. It like the
key mapping is off somewhat in most cases and not working at all in others. If
you type "qwerty", the 'q' acts as the 'w' and you get "wertyu¨ and the whole
bottom row of keys do not work at all. The caps lock does not work and the num
lock does not work along with the rest of the function keys. When I change the
driver back to "keyboard", everything appears to work fine. I noticed that the
"keyboard" driver is now depricated and was wondering if you could possibly not
take it out since it seems to work just fine on the Sun Ultra2's with the type5
keyboard. Here is my current keyboard settings in my xorg.conf file:

Section "InputDevice"
  Identifier  "Keyboard0"
  ##
  # This must be the Deprecated keyboard driver with xorg-x11-6.8.0-rxx
  #
  Driver      "keyboard"
#  Option      "Protocol"    "Standard"
#  Option      "XkbKeycodes" "sun(type5)"
#  Option      "XkbModel"    "type5"
#  Option      "XkbRules"    "sun"
#  Option      "XkbLayout"   "en_US"
#  Option      "XkbTypes"     "types/complete"
#  Option      "XkbCompat"   "compat/complete"
#  Option      "XkbGeometry" "sun(type5unix)"
   Option      "XkbRules"    "sun"
   Option      "XkbModel"    "type5_unix"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"  "basic"
EndSection


If I switch the driver to "kbd" it doesn't work properly.
Just thought I'd let you guys know.
Comment 1 Dejan Lesjak 2005-04-09 22:27:52 UTC
Same thing appears to happen on FreeBSD/sparc64 as reported on mailing list:
http://lists.freebsd.org/pipermail/freebsd-sparc64/2005-February/002691.html
http://lists.freebsd.org/pipermail/freebsd-sparc64/2005-February/002774.html

Furthermore this seems related to fix for 'keyboard' driver in bug #1722. I was 
unsuccesful in an attempt to carry the changes to 'kbd' driver.
It seems that this unfortunately makes 'kbd' driver unusable on sparc64 with 
Linux or FreeBSD so I believe this blocks bug #890 (removal of 'keyboard' 
driver) from closing.
Comment 2 Alan Hourihane 2005-07-12 23:04:16 UTC
Has anything happened on this ??
Comment 3 Alan Hourihane 2005-07-13 05:45:14 UTC
Created attachment 3075 [details] [review]
DRI: Sync via_dri.h

O.k, I don't think anything happened with this looking at CVS.

So I've come up with a fix that mimicks the behaviour of that in xf86Events.c
which allows the kbd driver to function on sun keyboards.

This has been tested on my type5 keyboard connected to an Ultra 60.

Any one got any problems if I commit this ?
Comment 4 Alan Hourihane 2005-07-13 22:25:44 UTC
O.k. There was a slight problem with that last patch, but I'm going to commit a
variation of it.

Closing.
Comment 5 Alan Hourihane 2005-07-14 05:28:14 UTC
*** Bug 1722 has been marked as a duplicate of this bug. ***
Comment 6 Alan Hourihane 2005-07-14 05:28:57 UTC
Comment on attachment 3075 [details] [review]
DRI: Sync via_dri.h

This patch is obsolete and not quite right. Use the CVS which the correct fix
has been committed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.