Bug 25933 - Rejects valid codec update
Summary: Rejects valid codec update
Status: NEW
Alias: None
Product: Telepathy
Classification: Unclassified
Component: gabble (show other bugs)
Version: 0.8
Hardware: Other All
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-06 18:34 UTC by Olivier Crête
Modified: 2010-05-18 22:54 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Crête 2010-01-06 18:34:08 UTC
The user initiate a call with the local codec "96 = H264, 97 = H263-1998".
The remote side (google video) replies with "97 = H264", which is set as remote codecs to tp-fs. And tp-fs replies with SupportedCodecs (97 = H264)

Afterwards, the CodecsUpdated call should the new list, not the original one. So 97 will be H264.

But currently, it seems that Gabble caches the origin one and tries apply updates to it so I get a spurious "Error calling Media.StreamHandler::CodecsUpdated: tried to change codec 97's name from H263-1998 to H264"..
Comment 1 Olivier Crête 2010-01-06 18:35:37 UTC
That said, I should mention for the record that the Google Video variant doesn't have the concept of updated codecs. So it is a concern for future interoperability.
Comment 2 Rafael Ballagas 2010-05-01 11:46:15 UTC
I'm still seeing this issue using Ubuntu 10.04:

$ dpkg -l | grep telepathy 
..(condensed)..
ii  libtelepathy-farsight0                      0.0.13-1                                        Glue library between telepathy and farsight2
ii  libtelepathy-glib0                          0.10.1-1ubuntu2                                 Telepathy framework - GLib library
ii  telepathy-gabble                            0.8.12-0ubuntu1                                 Jabber/XMPP connection manager
ii  telepathy-mission-control-5                 5.3.2-3                                         management daemon for Telepathy real-time co

When I use empathy to connect to google video:
Error calling Media.StreamHandler::CodecsUpdated: tried to change codec 97's name from JPEG2000 to H264

This results in a one-way video chat where I can see the remote video on empathy from Google Video, but not the remote video on Google Video from empathy

$ gst-inspect | grep 264
ffmpeg:  ffdec_h264: FFmpeg H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 decoder
ffmpeg:  ffmux_ipod: FFmpeg iPod H.264 MP4 format muxer
h264parse:  h264parse: H264Parse
x264:  x264enc: x264enc
rtp:  rtph264depay: RTP H264 depayloader
rtp:  rtph264pay: RTP H264 payloader
typefindfunctions: video/x-h264: h264, x264, 264


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.