Bug 26348 - debug output with drm.debug=1 is messed-up
Summary: debug output with drm.debug=1 is messed-up
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-31 04:48 UTC by Marc Dietrich
Modified: 2010-02-04 10:59 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
output of /var/log/messages (97.88 KB, text/plain)
2010-01-31 05:01 UTC, Marc Dietrich
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Dietrich 2010-01-31 04:48:03 UTC
setting debug to 1 in drm module and current kernel (2.6.33-rc6) gives only garbage in output. see attached log.
Comment 1 Marc Dietrich 2010-01-31 05:01:09 UTC
Created attachment 32945 [details]
output of /var/log/messages
Comment 2 Jesse Barnes 2010-02-04 09:30:43 UTC
Looks fine to me, just a lot of long lines and duplicated messages.  Try using dmesg to get the raw kernel data; looks like your syslog daemon is truncating things.
Comment 3 Marc Dietrich 2010-02-04 10:59:10 UTC
you are right, dmesg show the correct output. btw, this is rsyslogd from lucid. closing...


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.