Bug 28296 - [Pineview] mesa_demos_gltestperf causes GPU hang
[Pineview] mesa_demos_gltestperf causes GPU hang
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
unspecified
All Linux (All)
: medium normal
Assigned To: Eric Anholt
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 00:55 UTC by Yi Sun
Modified: 2010-08-09 01:30 UTC (History)
0 users

See Also:


Attachments
log file (134.56 KB, application/octet-stream)
2010-05-28 00:56 UTC, Yi Sun
Details
error state file (757.72 KB, text/plain)
2010-05-28 00:56 UTC, Yi Sun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yi Sun 2010-05-28 00:55:31 UTC
System Environment:
--------------------------

Libdrm:         (master)fcf3e616eeeb289f96af1436d809f0a1a42bebb7
Mesa:           (7.8)2eb5bc5add274634a536ce2094f877fd974d771f
Xserver:                (master)495cec794dad95ed0c79048f3c410ad23e7d5ea4
Xf86_video_intel:               (master)9d8ac271404ff219c3d40ae8f829e8b76ac7c359
Cairo:          (master)2f0f4ed0e2ae5657dedfe180b7be3a2496753ba8
Kernel: v2.6.34

Bug detailed description:
-------------------------
GPU hangs when the case gltestperf runs. We run the case on two Pineview machines, one is meego system and the other is Fedora 12. 



Reproduce steps:
----------------
1.xinit&
2. /mesa/demos/gltestperf
Comment 1 Yi Sun 2010-05-28 00:56:02 UTC
Created attachment 35902 [details]
log file
Comment 2 Yi Sun 2010-05-28 00:56:52 UTC
Created attachment 35903 [details]
error state file
Comment 3 Yi Sun 2010-08-06 01:53:24 UTC
we tested the two machine in which the issue can be reproduced. We use the kernel 2.6.35 and the latest mesa(master). The issue doesn't come out again.
But, we found some new issue: after we finished the gltestperf testing and then run compiz, the gnome will crash. And mutter(in meego) won't be started either.
Comment 4 Gordon Jin 2010-08-07 02:28:06 UTC
I'd suggest closing this bug and filing a new bug for the new issue.