Bug 28924 - [ILK] piglit tex-border-1 fail
[ILK] piglit tex-border-1 fail
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
8.0
All Linux (All)
: medium normal
Assigned To: Kenneth Graunke
:
: 37392 37738 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 19:05 UTC by Gordon Jin
Modified: 2012-02-17 01:43 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordon Jin 2010-07-05 19:05:44 UTC
piglit/tests/texturing/tex-border-1 has been fail since Eric added the case on Jun 15th.

Output:
Probe at (12,12)
  Expected: 1.000000 0.000000 0.000000
  Observed: 0.125490 0.027451 0.000000
Probe at (37,12)
  Expected: 0.000000 1.000000 0.000000
  Observed: 0.125490 0.027451 0.000000
Probe at (12,37)
  Expected: 0.000000 0.000000 1.000000
  Observed: 0.125490 0.027451 0.000000
Probe at (37,37)
  Expected: 1.000000 1.000000 1.000000
  Observed: 0.125490 0.027451 0.000000
PIGLIT: {'result': 'fail' }

Tested on Piketon with mesa master.
Comment 1 Eric Anholt 2011-05-25 09:20:35 UTC
*** Bug 37392 has been marked as a duplicate of this bug. ***
Comment 2 Eric Anholt 2011-06-05 21:31:50 UTC
*** Bug 37738 has been marked as a duplicate of this bug. ***
Comment 3 Kenneth Graunke 2012-01-25 01:22:44 UTC
Fixed on master by:

commit c25e5300cba7628b58df93ead14ebc3cc32f338c
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Fri Jan 20 03:33:40 2012 -0800

    i965: Fix border color on Sandybridge and Ivybridge.
    
    While reading through the simulator, I found some interesting code that
    looks like it checks the sampler default color pointer against the bound
    set in STATE_BASE_ADDRESS.  On failure, it appears to program it to the
    base address itself.
    
    So I decided to try programming a legitimate bound, and lo and behold,
    border color worked.
    
    +92 piglits on Sandybridge.  Also fixes Lightsmark on Ivybridge.
    
    NOTE: This is a candidate for stable release branches.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=28924
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=38868
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Yuanhan Liu <yuanhan.liu@linux.intel.com>
    Reviewed-by: Eric Anholt <eric@anholt.net>

This has also been cherry-picked to the 8.0 branch as commit 8e42dadf70ea2d359ef2c6d07a9a4da6d0b8e2da.
Comment 4 fangxun 2012-02-06 19:07:55 UTC
Verified with Mesa 8.0 branch(65b500857e) and master branch(1f4a853b1e46).
Comment 5 Kenneth Graunke 2012-02-08 12:54:30 UTC
Reopening this bug as it still fails on Ironlake.  Thankfully, only on Ironlake.
Comment 6 Kenneth Graunke 2012-02-10 20:50:11 UTC
Fixed in master by:

commit 3340b47c2280346ba2f44dde44466f09d898b9d8
Author: Kenneth Graunke <kenneth@whitecape.org>
Date:   Wed Feb 8 17:14:15 2012 -0800

    i965: Fix border color on Ironlake.
    
    Ironlake appears to check our pointer against the General State Base
    Address upper bound, rather than ignoring the zero bound as it ought.
    
    Unfortunately, since we leave GSBA set to zero, there is no logical
    upper bound.  Set it to the maximum possible value, which should work
    since our virtual addresses only go up to 2GB.
    
    +94 piglits.
    
    NOTE: This is a candidate for stable release branches.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=28924
    Signed-off-by: Kenneth Graunke <kenneth@whitecape.org>
    Reviewed-by: Eric Anholt <eric@anholt.net>

Leaving open until the 8.0 cherry-pick.
Comment 7 fangxun 2012-02-17 01:43:51 UTC
Verified with mesa master(78734e375a) and 8.0 branch(99f9c9789a2d) on Ironlake.