Bug 29491 - xf86-video-xgi does not work with recent servers
Summary: xf86-video-xgi does not work with recent servers
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/XGI (show other bugs)
Version: git
Hardware: All Linux (All)
: medium major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-10 12:50 UTC by Johannes Obermayr
Modified: 2014-11-17 21:47 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Build log (41.97 KB, text/plain)
2011-11-01 05:00 UTC, Johannes Obermayr
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Johannes Obermayr 2011-11-01 05:00:27 UTC
Created attachment 52994 [details]
Build log

Above links are obsolete.

I: Program is using implicit definitions of functions getting
   pointers or implemented by macros. These functions need to use their
   correct prototypes to allow correct argument passing on e.g. x86_64 .
     - Implicit memory/string functions need #include <string.h>.
     - Implicit *printf functions need #include <stdio.h>.
     - Implicit *printf functions need #include <stdio.h>.
     - Implicit *read* functions need #include <unistd.h>.
     - Implicit *recv* functions need #include <sys/socket.h>.
W: xorg-x11-driver-video implicit-pointer-decl xgi_driver.c:2950, 2952
E: xorg-x11-driver-video 64bit-portability-issue xgi_dri.c:288
E: xorg-x11-driver-video 64bit-portability-issue xgi_driver.c:3053
E: xorg-x11-driver-video 64bit-portability-issue xgi_setup.c:590

I: Program returns random data in a function
E: xorg-x11-driver-video no-return-in-nonvoid-function vb_i2c.c:1647, 1635
E: xorg-x11-driver-video no-return-in-nonvoid-function xgi_accel.c:948

Caused by:
xgi_driver.c:2950:9: warning: implicit declaration of function 'open' [-Wimplicit-function-declaration]
xgi_driver.c:2952:13: warning: implicit declaration of function 'ioctl' [-Wimplicit-function-declaration]
xgi_dri.c:288:42: warning: assignment makes pointer from integer without a cast [enabled by default]
xgi_driver.c:3053:36: warning: assignment makes pointer from integer without a cast [enabled by default]
xgi_setup.c:590:29: warning: assignment makes pointer from integer without a cast [enabled by default]

vb_i2c.c: In function 'bReadDataLine':
vb_i2c.c:1647:1: warning: control reaches end of non-void function [-Wreturn-type]
vb_i2c.c: In function 'bReadClockLine':
vb_i2c.c:1635:1: warning: control reaches end of non-void function [-Wreturn-type]
xgi_accel.c: In function 'Volari_AccelInit':
xgi_accel.c:948:1: warning: control reaches end of non-void function [-Wreturn-type]

There are some more warnings (see attachment).
Comment 2 Jeremy Huddleston Sequoia 2011-11-01 10:23:30 UTC
As I mentioned in my email to xorg-devel, the xgi driver's "serious problems" have caused it to not work for the better part of the last decade.  Because of that, I'm not willing to invest my time in fixing it since it appears nobody even uses it.

If you do actually use it, then I would solicit a patch from you to fix the problems since you're also in a better position to test the results.


bug/show.html.tmpl processed on Jun 25, 2016 at 14:03:23.
(provided by the Example extension).