Bug 29861 - Cryptic error message from autogen.sh when gobject-introspection is not installed
Summary: Cryptic error message from autogen.sh when gobject-introspection is not insta...
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-29 00:36 UTC by Marat Radchenko
Modified: 2010-08-29 03:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marat Radchenko 2010-08-29 00:36:25 UTC
1. Make sure you don't have gobject-introspection installed
2. Run autogen.sh

Expected: error tells you you don't have gobject-introspection.

Actual:
lib/packagekit-glib2/Makefile.am:234: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
autoreconf-2.65: automake failed with exit status: 1
Comment 1 Richard Hughes 2010-08-29 03:16:26 UTC
commit 1acc2b448409ba999506a0574e5283f86c077085
Author: Richard Hughes <richard@hughsie.com>
Date:   Sun Aug 29 11:16:26 2010 +0100

    Ensure gobject-introspection is installed before running configure. Fixes #29861


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.