Bug 30154 - [i965] GLSL noise function not properly supported
[i965] GLSL noise function not properly supported
Status: CLOSED WONTFIX
Product: Mesa
Classification: Unclassified
Component: glsl-compiler
git
All Linux (All)
: medium enhancement
Assigned To: Ian Romanick
:
: 30153 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-12 20:22 UTC by wang,jinjin
Modified: 2014-12-19 02:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wang,jinjin 2010-09-12 20:22:22 UTC
System Environment:
--------------------------
Arch:           x86_64
Platform:       Piketon
OSD:            Fedora release 13 (Goddard)
Libdrm:         (master)2.4.21-21-g7ec9a1effa4f551897f91f3b017723a8adf011d9
Mesa:           (master) c4046d4fda2fe838659bff99bfa17f57f895a943
Xf86_video_intel:              
(master)2.12.0-86-gae160d7fbfc79e78dad8702efcc55d9c0c25ff67
Cairo:          (master)36018ac7ce4285367d3168fc09a0d046c04e238e
Kernel: (master)9fe6206f400646a2322096b56c59891d530e8d51

Bug detailed description:
---------------------------
With Mesa (master) c4046d4fda2fe838659bff99bfa17f57f895a943, Mesa demo multinoise can not change the color of teapot in displaying using i965.But it run correctly using swrast.
You can see bug#29524 for more details.

Reproduce steps:
----------------
1.xinit& 
2. Mesa_demos/src/glsl/multinoise
3.change the teapot color with button on keyboard according to  the codes such
as “a”、“2”
Comment 1 Ian Romanick 2010-09-13 09:57:56 UTC
I've changed the summary and degraded this to an enhancement.  We're technically conformant with the GLSL spec, but this doesn't provide any useful functionality to developers.  It needs fixing, but it's not a priority right now.
Comment 2 Ian Romanick 2010-09-13 09:58:33 UTC
*** Bug 30153 has been marked as a duplicate of this bug. ***
Comment 3 Kenneth Graunke 2010-12-25 23:26:42 UTC
Moving this to the glsl-compiler component, since I believe all the actual work to enable a non-zero noise implementation will be done there.
Comment 4 bo.b.wang 2011-03-10 17:09:21 UTC
System Environment:
--------------------------
Platform:        Sandybrige
Libdrm:         (master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:           (7.10)3ed9054cc598a38d2cbcadd3f81943635148514c
Xserver:                (master)xorg-server-1.10.0
Xf86_video_intel:               (master)2.14.901-2-g049ce4397ddf7fd088ce364cbb53cacf5133176f
Cairo:          (master)f1d313e042af89b2f5f5d09d3eb1703d0517ecd7
Kernel: (drm-intel-fixes)467cffba85791cdfce38c124d75bd578f4bb8625

I have discovered this issue is appearing in Sandbrige Rev09.
Comment 5 Guang Yang 2011-11-04 02:15:32 UTC
This issue still happens with following commits:
Platform:       Pineview
Libdrm:         (master)2.4.27-1-g961bf9b5c2866ccb4fedf2b45b29fb688519d0db
Mesa:           (7.11)b95767a57ad499a2ed7431e8b0b52966c6dc0a45
Xserver:           (server-1.11-branch)xorg-server-1.11.1
Xf86_video_intel:  (master)2.16.901-31-g6fd0754e9c81164ca0fdcf96ba2bfb419568187f
Cairo:          (master)c64ec4e49c1f06a451187d5f8360df09a777f61c
Kernel:         (master)c3b92c8787367a8bb53d57d9789b558f1295cc96
Comment 6 Ian Romanick 2014-12-17 20:14:02 UTC
GLSL should never have included noise() functions, and no applications use it.