Bug 30213 - ION2 (NV50) locks up with infinite loop
Summary: ION2 (NV50) locks up with infinite loop
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: 7.5 (2009.10)
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-15 07:39 UTC by Jeff Mahoney
Modified: 2013-08-18 18:09 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (77.52 KB, text/plain)
2010-09-15 07:39 UTC, Jeff Mahoney
no flags Details
dmesg output (59.20 KB, text/plain)
2010-09-15 07:40 UTC, Jeff Mahoney
no flags Details
hwinfo output (425.67 KB, text/plain)
2010-09-15 07:41 UTC, Jeff Mahoney
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Mahoney 2010-09-15 07:39:53 UTC
Created attachment 38722 [details]
Xorg.0.log

Under normal operation, the display locks up. The keyboard becomes nonresponsive, but the mouse (and cursor movement) still works. The display stays coherent but is just frozen in time.

Attached are both the kernel log and Xorg.0.log, as well as the hwinfo (openSUSE tool) that describes the hardware in detail. The kernel log changes and I've seen this hang appear without any entry in the kernel log.

On my system, this issue is reproduced trivially by playing video with totem.
Comment 1 Jeff Mahoney 2010-09-15 07:40:43 UTC
Created attachment 38723 [details]
dmesg output
Comment 2 Jeff Mahoney 2010-09-15 07:41:17 UTC
Created attachment 38724 [details]
hwinfo output
Comment 3 Marcin Slusarz 2010-09-15 08:48:10 UTC
this is probably a duplicate of bug 26980

(your card is NVA8)
Comment 4 Robert Kaiser 2010-09-15 09:01:41 UTC
In very recent versions of openSUSE Factory, I'm seeing a similar problem with my NV4B card, and I haven't seen this before. When I activate KDE Compositiong (which finally works somewhat), it happens very fast, else it happens rarely, but sometimes. If it happens, logging into the machine remotely, only a kill -9 works to end Xorg, which is busy at 100% CPU, then the screen goes black and can't be brought back to displaying naything unless with a reboot.
Comment 5 Marcin Slusarz 2011-12-05 12:41:44 UTC
Bug 26980 was fixed in 2.6.39.
Jeff, can you check whether it fixed your issue too?
Comment 6 Ilia Mirkin 2013-08-18 18:09:17 UTC
It appears that this bug report has laid dormant for quite a while. Sorry we haven't gotten to it. Since we fix bugs all the time, chances are pretty good that your issue has been fixed with the latest software. Please give it a shot. (Linux kernel 3.10.7, xf86-video-nouveau 1.0.9, mesa 9.1.6, or their git versions.) If upgrading to the latest isn't an option for you, your distro's bugzilla is probably the right destination for your bug report.

In an effort to clean up our bug list, we're pre-emptively closing all bugs that haven't seen updates since 2011. If the original issue remains, please make sure to provide fresh info, see http://nouveau.freedesktop.org/wiki/Bugs/ for what we need to see, and re-open this one.

Thanks,

The Nouveau Team


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.