Bug 3057 - Xv distortion and lockup
Summary: Xv distortion and lockup
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-04-18 08:05 UTC by furryball
Modified: 2005-05-09 20:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Log file (48.81 KB, application/x-trash)
2005-04-18 08:06 UTC, furryball
no flags Details
Logs of the attempt (45.86 KB, text/x-log)
2005-04-18 09:13 UTC, furryball
no flags Details
My settings (16.63 KB, text/plain)
2005-04-18 09:14 UTC, furryball
no flags Details
The same happens again (53.01 KB, application/octet-stream)
2005-04-18 10:02 UTC, furryball
no flags Details
The enhanced logs of the crash (43.73 KB, application/x-tbz)
2005-04-26 11:16 UTC, furryball
no flags Details
Logs with the next version (12.01 KB, application/x-tbz)
2005-04-26 12:22 UTC, furryball
no flags Details
There we go again! (14.62 KB, application/x-tbz)
2005-04-27 13:12 UTC, furryball
no flags Details
More more more (14.10 KB, application/x-tbz)
2005-04-27 13:30 UTC, furryball
no flags Details
Not quite yet (27.15 KB, application/x-tbz)
2005-04-27 15:23 UTC, furryball
no flags Details
Almost there but not yet (28.31 KB, application/x-tbz)
2005-04-28 04:17 UTC, furryball
no flags Details
There we went again. (14.71 KB, application/x-tbz)
2005-04-28 06:44 UTC, furryball
no flags Details

Description furryball 2005-04-18 08:05:31 UTC
When I try to play videos using XV I have approx. 1/5 chance of very weird  
behaviour.  
  
The video gets initialized (from what I can see) and then the whole screen  
rolls horizontally very fast like on a really broken television. After that the  
screen goes black and keyboard/mouse are unresponsive.   
  
SSHing to the computer reveals couple things.  
  
There is a kernel process something like [krootimg] and it's defunct. There are  
also couple "udev xv" processes hanging. Killing X removes them and everything  
works perfectly afterwards.  
  
I have i865G and everything has worked earlier just fine. I can't however point  
to any specific upgrade. I would appreciate any ideas.
Comment 1 furryball 2005-04-18 08:06:06 UTC
Created attachment 2444 [details]
Log file

This log will show something getting smashed up.. You tell me what?
Comment 2 Alan Hourihane 2005-04-18 08:35:54 UTC
You might want to give my updated i810 driver a try that's available
at http://www.fairlite.demon.co.uk/intel.html and see if that helps.

Make sure you back up the old one just in case, and re-report here. Thanks.
Comment 3 furryball 2005-04-18 09:13:42 UTC
Created attachment 2448 [details]
Logs of the attempt

With that driver X won't start up at all.
Comment 4 furryball 2005-04-18 09:14:25 UTC
Created attachment 2450 [details]
My settings

In case these could help. I tried disabling dri/gl for the last attempt btw.
Comment 5 Alan Hourihane 2005-04-18 09:26:27 UTC
Sorry, my fault, I've just uploaded another. Try that.
Comment 6 furryball 2005-04-18 10:02:39 UTC
Created attachment 2452 [details]
The same happens again

This time I got actually to see a video. For the first time. When I stopped,
the crash happened. And this time 
root	  1811	0.0  0.0      0     0 ?        Z    19:50   0:00 [krootimage]
<defunct>
won't get killed.. Ah well, time to reboot.
Comment 7 Alan Hourihane 2005-04-18 10:57:09 UTC
Can you tell me which player are you using and the version of it ?

Also, does it happen with all videos or just a specific one ?
Comment 8 Alan Hourihane 2005-04-18 10:58:12 UTC
Also, are you running a 2.6.11 kernel ?

If so, maybe it's the kernel upgrade if you say it's worked before ?
Comment 9 furryball 2005-04-18 12:18:10 UTC
*  media-libs/xine-lib 
      Latest version available: 1.0-r1 
      Latest version installed: 1.0-r1 
*  media-video/mplayer 
      Latest version available: 1.0_pre6-r5 
      Latest version installed: 1.0_pre6-r5 
 
2.6.11.7 but I've tried with the newer ones as well.. And with all media files, 
assorted formats & codecs etc. There isn't any sane pattern in them. 
 
Now this will take a moment to isolate the sucker. My previous experiences are 
with xine-lib based players. I will test with mplayer backend and with the 
older kernel versions.  
 
At this moment however I can't seem to be able to crash anything! (Though I 
have done it ~5 times a day for the last couple weeks.) The bug - whatever it 
is - is elusive. I would like more dependable bugs more. :-P 
 
As I know that I have had problems with xine-lib based players I will use 
mplayer for a while. If the bug doesn't appear up, there's a hint. If it does, 
I will try with the older kernels. If it still does, ah well.. But this might 
take couple days unless if I got really lucky. 
 
Comment 10 furryball 2005-04-21 05:05:23 UTC
I have tested out this now enough to be almost sure of the following: 
- Kernel version shouldn't change the behavior 
- I can't get mplayer based stuff crashing 
- It seems to be xine-lib based players that are causing trouble 
 
- It might be that specifically Kaffeine (that uses xine as the backend) is 
causing the crash but not the other xine based players. I am not sure about 
this one. 
 
My kaffeine is kaffeine-0.6 
 
Comment 11 Alan Hourihane 2005-04-21 05:11:43 UTC
So the same video plays fine with mplayer but not with kaffeine ?
Comment 12 Alan Hourihane 2005-04-22 11:01:38 UTC
I've uploaded a new driver on my web site that has some debugging enabled in the
log and a few updates for Xv. Give that a try, and if it still happens attach a
new log that should show me some more details on what's happening.
Comment 13 furryball 2005-04-26 11:16:31 UTC
Created attachment 2559 [details]
The enhanced logs of the crash

Yes, I got no problems with mplayer based stuff it seems. I am sorry this took
a bit since I had to (because of other reasons) rebuild all my software
completely from scratch.. (Compiling stuff like KDE on my older P4 takes ages.)

Here's the 2 log files that I found after the crash. I had to run through a few
dozen long videos to get the bug appear so there's 10+ megabytes of it. I
thought however that you can spot the important parts, if there are such..
Comment 14 furryball 2005-04-26 11:23:00 UTC
This time I got the crash when Kaffeine initiated the xine-lib / xv stuff. I 
managed to see the first frame(s) of the videos for a few split seconds and 
then POOF. 
Comment 15 Alan Hourihane 2005-04-26 11:32:00 UTC
I've uploaded a new driver to try at my website again. Can you try that as it
has more debugging information.
Comment 16 furryball 2005-04-26 12:22:17 UTC
Created attachment 2562 [details]
Logs with the next version

Ok, that took only a few seconds.. Seeing anything of use?
Comment 17 Alan Hourihane 2005-04-27 11:23:26 UTC
I'm tracking something that may be causing it, but I've uploaded another version
with yet more debugging. Try again.
Comment 18 furryball 2005-04-27 13:12:37 UTC
Created attachment 2578 [details]
There we go again!

Ok. Now I took a look at the log.. The last a few lines.. Is that a joke?!
Comment 19 furryball 2005-04-27 13:30:13 UTC
Created attachment 2579 [details]
More more more

These seem slightly different? I will upload an other set just in case..
Comment 20 Alan Hourihane 2005-04-27 14:50:16 UTC
I've uploaded another to try. This will hopefully help.
Comment 21 furryball 2005-04-27 15:23:10 UTC
Created attachment 2580 [details]
Not quite yet

It seemed at first that it would work. At the most usual crash positions there
was a delay/hickup for a tiny amount of time but there was no crash. I kept
trying and managed once more to smash it.
Comment 22 Alan Hourihane 2005-04-27 15:59:55 UTC
O.k. It seems as though your application creates a really small video window for
a  single frame which causes the downscaling to overflow.

I've uploaded another test driver to see if it helps.
Comment 23 furryball 2005-04-28 04:17:50 UTC
Created attachment 2582 [details]
Almost there but not yet

This time I can see the small blue canvas for the overlay on the upper left
corner. There is no spinning effect of the whole screen but it still locks up.
Comment 24 Alan Hourihane 2005-04-28 06:30:38 UTC
ok. it looks like there might be another path for overflow. Try the latest driver.
Comment 25 furryball 2005-04-28 06:44:02 UTC
Created attachment 2583 [details]
There we went again.

Crash Boom Bang.
Comment 26 Alan Hourihane 2005-04-28 06:55:05 UTC
O.k. Is there a chance I can get my hands on the video you are playing - legally ?

Rather than waste time with ping ponging ?

And just checking that you are still using kaffeine 0.6 ?
Comment 27 furryball 2005-04-28 07:08:04 UTC
Take for instance 
http://people.jyu.fi/~miersale/nationalanthem.wmv 
 
Yes, that Kaffeine version. 
 
Please note this: 
- I have got a few hundred video clips that can do the same. It is very 
unlikely that the "video file is somehow faulty", though it is possible as 
well. 
- It doesn't always happen with the same clip. It's pretty much random. 
- It doesn't always happen on the same spot (most usually at the first frame(s) 
though) 
- Most of the videos that have been able to do it have been of those Windows 
Media formats. Go figure. 
 
 
Comment 28 Alan Hourihane 2005-05-03 05:57:04 UTC
I've uploaded a new driver that works here. Try it and let me know how you get on.
Comment 29 Alan Hourihane 2005-05-10 13:19:43 UTC
I'll close this now as I can't replicate it with the latest version.

Re-open if you still have a problem.
Comment 30 Alan Hourihane 2005-05-10 13:20:05 UTC
I'll close this now as I can't replicate it with the latest version.

Re-open if you still have a problem.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.