Bug 31388 - Blue noise in Heroes of Newerth with newer mesa
Summary: Blue noise in Heroes of Newerth with newer mesa
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Eric Anholt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-04 12:14 UTC by Michael Groh
Modified: 2010-12-04 05:30 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
picture of the blue noise on my i965 (174.95 KB, image/jpeg)
2010-11-04 12:44 UTC, Michael Groh
Details
Xorg.0.log from the 965GM (73.23 KB, text/x-log)
2010-11-09 12:46 UTC, Michael Groh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Groh 2010-11-04 12:14:25 UTC
Hello everyone.

I am playing Heroes of Newerth from time to time. I am using libgl1-mesa-dri-7.10.0+git20101103.ab2305b5-0ubuntu0sarvatt2~maverick from the xorg-edgers overlay on kubuntu 10.10. 

Everytime i am playing HoN, there is this blue noise. It started appearing 1-2 months ago. Even when you have no account, the bug is visible on the login page using the linux client here: http://www.heroesofnewerth.com/download.php and if someone needs to get ingame, i can provide them with a testkey :)

i am happy to help, and if any information is missing, just ask.

thanks,

brot
Comment 1 Michael Groh 2010-11-04 12:44:41 UTC
Created attachment 40049 [details]
picture of the blue noise on my i965
Comment 2 Eric Anholt 2010-11-09 11:54:17 UTC
Not sure since you don't have any of the hardawre information in here (http://intellinuxgraphics.org/how_to_report_bug.html), but I'm guessing you're on a G965 or GM965 chipset?
Comment 3 Michael Groh 2010-11-09 12:42:00 UTC
Sorry, i didnt know that page.

Chipset is:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

on x86_64 2.6.36

Userland is:

libdrm-intel1 2.4.22+git20101108.49447a9b-0ubuntu0sarvatt3~maverick
xserver-xorg 7.5+6+xserver1.9
libgl1-mesa-glx/libgl1-mesa-dri 7.10.0+git20101108.ef6967dd-0ubuntu0sarvatt~maverick

System is a Dell Inspiron 1525
Comment 4 Michael Groh 2010-11-09 12:46:41 UTC
Created attachment 40166 [details]
Xorg.0.log from the 965GM
Comment 5 Chris Wilson 2010-11-30 06:54:15 UTC
*** Bug 31960 has been marked as a duplicate of this bug. ***
Comment 6 Chris Wilson 2010-12-04 05:30:30 UTC
commit de18a29e0fa3904894b4e02fae0e712cd43f740c
Author: Daniel Vetter <daniel.vetter@ffwll.ch>
Date:   Sat Nov 27 22:30:41 2010 +0100

    drm/i915: fix regression due to ba3d8d749b01548b9
    
    We don't track gpu flush request in any special way. So even with
    obj->write_domain == 0, a gpu flush might be outstanding but no
    yet executed. Even worse, the latest request might use the object
    only for reading. So and unconditional call to object_wait_rendering
    is needed for !pipelined.
    
    Hence revert that patch fully and untangle the flushing from the
    synchronization again.
    
    Reported-by: Keith Packard <keithp@keithp.com>
    Tested-by: Keith Packard <keithp@keithp.com>
    Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.