Bug 32 - xft.h/XftFreetype.h isn't installed in some case
Summary: xft.h/XftFreetype.h isn't installed in some case
Status: CLOSED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xft (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-19 02:12 UTC by popolon
Modified: 2011-10-15 17:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description popolon 2003-02-19 02:12:11 UTC
xft.h and XftFreetype.h aren't installed in /usr/X11R6/include/X11/Xft/ if there
is one already and more recent file (There was default Xfree Xft.h file)

i use --prefix=/usr/X11R6

Xfree Xft.h and XftFreetype.h includes was older version.

I use make 3.79.1

A version test could be a good thing (as done in pango 1.2.1)

#include <X11/Xft/Xft.h>
#if defined(XftVersion) && XftVersion >= 20000
#else
#error "must have Xft version 2 or newer"
#endif

and change it to, if oldere version -> install.
Comment 1 Keith Packard 2003-02-26 23:02:16 UTC
I'm confused by this description.  Are you saying that 'make install'
isn't installing files?
Comment 2 Keith Packard 2003-04-19 19:07:08 UTC
Ah.  XftFreetype.h shouldn't be installed any more; it shouldn't even be a part
of Xft version 2.  I'm removing it from the repository.
Comment 3 Jeremy Huddleston Sequoia 2011-10-01 14:12:38 UTC
Mass update: Close all bugs resolved over one year ago.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.