Bug 32459 - [softpipe] glean depthStencil regression
[softpipe] glean depthStencil regression
Status: CLOSED FIXED
Product: Mesa
Classification: Unclassified
Component: Other
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Brian Paul
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 15:50 UTC by Vinson Lee
Modified: 2011-01-03 11:26 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2010-12-16 15:50:21 UTC
mesa: 3ecf47af1252ad10f98d5ce488cc1b91fab64c25 (master)

glean depthStencil now fails but previously passed on softpipe.

$ glean -r results -t depthStencil --quick
Mesa: User error: GL_INVALID_ENUM in glDrawPixels(format or type)
Mesa: User error: GL_INVALID_OPERATION in glDrawPixels(format is not GL_DEPTH_STENCIL_EXT)
Mesa: User error: GL_INVALID_ENUM in glReadPixels(format or type)
Mesa: User error: GL_INVALID_OPERATION in glReadPixels(format is not GL_DEPTH_STENCIL_EXT)
depthStencilFAIL
	Image returned by glReadPixels didn't match the expected result (0x0 != 0xff)
Comment 1 Vinson Lee 2010-12-16 16:00:43 UTC
c62bb90d6a864468fe1a717aebb9c1a9c43bf3c8 is the first bad commit
commit c62bb90d6a864468fe1a717aebb9c1a9c43bf3c8
Author: Brian Paul <brianp@vmware.com>
Date:   Tue Dec 14 13:01:00 2010 -0700

    softpipe: do texture swizzle during texture sampling
    
    Instead of when we read texture tiles.  Now swizzling happens after
    the shadow depth compare step.  This fixes the piglit glsl-fs-shadow2d*
    tests (except for proj+bias because of a GLSL bug).

:040000 040000 4d10bf9229786b1d75b419548d83adba7fb5751b e44f13680425a59196a9133aec126350dd21c955 M	src
bisect run success
Comment 2 Brian Paul 2010-12-16 16:40:35 UTC
Fixed with commit 9d9f8aba0aa51f707ac1d451fb8a89bb95676ab1
Comment 3 Vinson Lee 2011-01-03 11:26:40 UTC
mesa: ada9c78c29ef11720d464211c098b740f8aa11a4 (master)

Verified fixed.