Bug 32604 - E̊ and e̊ not available. They are used in some dialects of Walloon and Picard.
Summary: E̊ and e̊ not available. They are used in some dialects of Walloon and Picard.
Status: RESOLVED MOVED
Alias: None
Product: xorg
Classification: Unclassified
Component: Lib/Xlib (data) (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard: 2011BRB_Reviewed
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-23 04:16 UTC by Jean-François Colson
Modified: 2018-08-10 20:12 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
E̊ e̊ IJ ij J̀ j̀ J́ j́ (a few compose key sequences for the en_US locale) (1.36 KB, text/plain)
2011-01-01 04:17 UTC, Jean-François Colson
no flags Details
adds compose sequences for E and e with combining ring above (2.35 KB, patch)
2013-09-10 12:23 UTC, Benno Schulenberg
no flags Details | Splinter Review
adds several sequences for E and e with combining ring above (3.15 KB, patch)
2013-09-10 18:23 UTC, Benno Schulenberg
no flags Details | Splinter Review
adds extensive sequences for E and e with combining ring above (3.73 KB, patch)
2013-09-16 14:45 UTC, Benno Schulenberg
no flags Details | Splinter Review
adds extensive sequences for E and e with combining ring above (3.79 KB, patch)
2014-05-29 15:30 UTC, Benno Schulenberg
no flags Details | Splinter Review

Description Jean-François Colson 2010-12-23 04:16:46 UTC
Hello

In Walloonia, Nord-Pas-de-Calais and Picardy, the official language is French. But there are also local languages such as Walloon and Picard.

In some dialects of those two languages, the letter E with ring above is used. Nevertheless, it is not included in the ISO-8859-1 character set, and that's why you can find documents such as this version of the Universal Declaration of Human Rights in Picard (http://www.ohchr.org/EN/UDHR/Documents/UDHR_Translations/frn2.pdf) where “e̊” is replaced by “e°” and “E̊”, by “E°”.

In order to diminish the need for such a surrogate, it would be wise to add the next two lines into the file /usr/share/X11/locale/en_US.UTF-8/Compose:

<dead_abovering> <E>		: "E̊"		# LATIN CAPITAL LETTER E WITH COMBINING RING ABOVE
<dead_abovering> <e>		: "e̊"		# LATIN SMALL LETTER E WITH COMBINING RING ABOVE
Comment 1 James Cloos 2010-12-24 10:23:00 UTC
Are there any other combined characters which would benefit
Walloon, Picard or other nearby local languages?

Unfortunately, the Multi_key sequence used for RING ABOVE
for ÅåŮůẘẙ, <Multi_key><o>, is also used for a number of
non-diacritic compositions, namely ©®œ§¤.

But that shouldn't prevent adding the <dead_abovering>
sequences.
Comment 2 Jean-François Colson 2010-12-25 10:03:54 UTC
(In reply to comment #1)

> Unfortunately, the Multi_key sequence used for RING ABOVE
> for ÅåŮůẘẙ, <Multi_key><o>, is also used for a number of
> non-diacritic compositions, namely ©®œ§¤.

You're right: I forgot about that.
In fact, I type in bépo and, since I took part a little in its development, I perfectly know the location of the different characters, including the 20 dead keys.
But most people in the French speaking part of Belgium type on different azerty layouts, it is more than possible that some of them don't know the location of the dead ring above and it is not impossible at all that some will use a keyboard layout without any dead key. Therefore a way to type that letter with only ASCII characters and the Compose key would be welcome.

Since œ is used in French, we shouldn't modify the Compose + o + e key sequence.
Why couldn't we use Compose + O + e instead?
That way, we'd have
① Compose + o + e → œ
② Compose + O + E → Œ
③ Compose + O + e → e̊
④ Compose + o + E → E̊
That would work, that would be easy to remember, and that would avoid the conflict between e̊ and œ.

So, here are the 4 lines to add to the file /usr/share/X11/xkb/en_US.UTF-8/Compose:

<dead_abovering> <E>         : "E̊"       # LATIN CAPITAL LETTER E WITH COMBINING RING ABOVE
<dead_abovering> <e>         : "e̊"       # LATIN SMALL LETTER E WITH COMBINING RING ABOVE
<Multi_key> <o> <E>          : "E̊"       # LATIN CAPITAL LETTER E WITH COMBINING RING ABOVE
<Multi_key> <O> <e>          : "e̊"       # LATIN SMALL LETTER E WITH COMBINING RING ABOVE






> Are there any other combined characters which would benefit
> Walloon, Picard or other nearby local languages?

I don't think so, However I don't know all the dialects of all the languages.
But on the official languages level, there is Dutch (the official language of Flanders and the Netherlands).

First, there is the digraph IJ / ij. It is most often written as a two letter sequence IJ / ij, but it is not forbidden to use the ligature IJ / ij.

I think I remember there's no Compose sequence for that ligature.

Could you add

<Multi_key> <I> <J>          : "IJ" U0132 # LATIN CAPITAL LIGATURE IJ
<Multi_key> <i> <j>          : "ij" U0133 # LATIN SMALL LIGATURE IJ

?

Also, although that's not compulsory, it is quite common, in Dutch, to use an acute or a grave on a vowel (or on each component of a diphtong) to mark the emphasis or a stress.

ij is a diphtong /ɛi/ and I've already met the word hij with two graves (hìj̀), but acutes could be used too (híj́).

Could you add support for the letter J / j with acute and with grave? Here is what that'd look like:

<dead_grave> <J>             : "J̀"       # LATIN CAPITAL LETTER J WITH COMBINING GRAVE
<dead_grave> <j>             : "j̀"       # LATIN SMALL LETTER J WITH COMBINING GRAVE
<Multi_key> <grave> <J>      : "J̀"       # LATIN CAPITAL LETTER J WITH COMBINING GRAVE
<Multi_key> <grave> <j>      : "j̀"       # LATIN SMALL LETTER J WITH COMBINING GRAVE

<dead_acute> <J>             : "J́"       # LATIN CAPITAL LETTER J WITH COMBINING ACUTE
<dead_acute> <j>             : "j́"       # LATIN SMALL LETTER J WITH COMBINING ACUTE
<Multi_key> <acute> <J>      : "J́"       # LATIN CAPITAL LETTER J WITH COMBINING ACUTE
<Multi_key> <acute> <j>      : "j́"       # LATIN SMALL LETTER J WITH COMBINING ACUTE
<Multi_key> <apostrophe> <J> : "J́"       # LATIN CAPITAL LETTER J WITH COMBINING ACUTE
<Multi_key> <apostrophe> <j> : "j́"       # LATIN SMALL LETTER J WITH COMBINING ACUTE

I have a lot more Compose sequences to propose but I'm still working on some of them. That's enough for now.

To sum up, here are the Compose sequences I suggest: http://compose_proposals.colson.eu/ering_ij
Comment 3 Jean-François Colson 2011-01-01 04:17:49 UTC
Created attachment 41552 [details]
E̊ e̊ IJ ij J̀ j̀ J́ j́ (a few compose key sequences for the en_US locale)

In case the link I've given a few days ago wouldn't work, here is the same file as an attachment. Its contents should simply be added in the Compose file of the locale en_US (on my OS, it's the file /usr/share/X11/locale/en_US.UTF-8/Compose).
Comment 4 Jeremy Huddleston Sequoia 2011-10-09 02:42:06 UTC
Jean, would you mind sending a patch to xorg-devel for review?
Comment 5 Jean-François Colson 2013-08-10 23:08:00 UTC
(In reply to comment #4)
> Jean, would you mind sending a patch to xorg-devel for review?

Yes, Je (*), I could if I knew how to do it.
Is there a tutorial somewhere about how to make a patch?
I know which file to change on my computer, I know what changes to do but I don’t know how to make a patch. Should I send the whole modified file or only the modified part? Or perhaps the modified part plus a few lines before and after?

(*) My first name is Jean-François, not Jean.
Comment 6 Benno Schulenberg 2013-08-11 07:39:03 UTC
(In reply to comment #5)

A patch you make with 'diff -u'.  For example:

  diff -u  originalfile  modifiedfile  >thedifferences.patch

See for more details 'man patch' and 'info diff'.
Comment 7 Jean-François Colson 2013-08-11 23:58:51 UTC
(In reply to comment #6)
> (In reply to comment #5)
> 
> A patch you make with 'diff -u'.  For example:
> 
>   diff -u  originalfile  modifiedfile  >thedifferences.patch
> 
> See for more details 'man patch' and 'info diff'.

Oh! That’s so simple? If only I had known it before…

Another question: which file should I take as the original file?
cgit.freedesktop.org/xorg/lib/libX11/plain/nls/en_US.UTF-8/Compose.pre
or
/usr/share/X11/locale/en_US.UTF-8/Compose
?
Comment 8 Benno Schulenberg 2013-08-12 07:40:38 UTC
(In reply to comment #7)
> Another question: which file should I take as the original file?
> cgit.freedesktop.org/xorg/lib/libX11/plain/nls/en_US.UTF-8/Compose.pre
> or
> /usr/share/X11/locale/en_US.UTF-8/Compose
> ?

Well, you have already guessed.  :)  The most recent one,
the most up-to-date one, the first one, the one from git.
Comment 9 Benno Schulenberg 2013-09-08 16:19:38 UTC
Jean-François, are you working on a patch?  Or shall I make it for you?
Comment 10 Jean-François Colson 2013-09-10 10:01:20 UTC
(In reply to comment #9)
> Jean-François, are you working on a patch?  Or shall I make it for you?

Will this (http://colson.eu/WalDutch) do the job?
Comment 11 Jean-François Colson 2013-09-10 11:01:09 UTC
(In reply to comment #4)
> Jean, would you mind sending a patch to xorg-devel for review?

I tried to change xorg-team@lists.x.org to xorg-devel@lists.x.org in the “Assigned To” field above, but that didn’t work.

How can I send the patch to xorg-devel?
Comment 12 Benno Schulenberg 2013-09-10 12:21:25 UTC
(In reply to comment #10)
> Will this (http://colson.eu/WalDutch) do the job?

It will do as an example, but it is not a patch.  It is not even a unified diff (diff -u) but a plain old unusable contextless diff.  I will attach a patch in a minute.  It will also fix the mistaken <O> <e> sequence to <o> <e>.

The sequences for the IJ and ij ligatures already exist in the compose tables, and the one for J and j with combining acute too, so they do not need to be added again.  The ones with combining graves I do not wish to add to the patch, first because it's completely unrelated to Walloon or Picard, and second because I would never put graves on ij if I wished to stress this vowel, I would use acutes.  But yes, in theory you are correct: if á and à and é and è (and so on) exist, then also j́ and j̀ need to exist to make the range of stressed vowels complete.  But I think this is better put into a different patch -- it's hard enough to get the Xorg people to accept some simple compose additions that people actually want to use.
Comment 13 Benno Schulenberg 2013-09-10 12:23:34 UTC
Created attachment 85561 [details] [review]
adds compose sequences for E and e with combining ring above
Comment 14 Benno Schulenberg 2013-09-10 12:27:11 UTC
(In reply to comment #11)
> How can I send the patch to xorg-devel?

You will have to use your mailer to send an actual email with the patch attached or inlined to < xorg-devel AT list.x.org >, give your grounds for the addition and refer to this bug.
Comment 15 Jean-François Colson 2013-09-10 14:25:54 UTC
(In reply to comment #12)
> (In reply to comment #10)
> > Will this (http://colson.eu/WalDutch) do the job?
> 
> It will do as an example, but it is not a patch.  It is not even a unified
> diff (diff -u)

I first forgot the “-u” and I uploaded a new version of the file a few minutes later. Perhaps you downloaded the first version.

> but a plain old unusable contextless diff.  I will attach a
> patch in a minute.  It will also fix the mistaken <O> <e> sequence to <o>
> <e>.

That wasn’t a mistake at all. That was intended to avoid a conflict with <o> <e> which is used for œ.
Look at https://bugs.freedesktop.org/show_bug.cgi?id=32604#c2

> 
> The sequences for the IJ and ij ligatures already exist in the compose
> tables

I forgot about that.

> , and the one for J and j with combining acute too,

Really? That’s nice! I didn’t notice because they aren’t available yet on my computer.

> so they do not
> need to be added again.  The ones with combining graves I do not wish to add
> to the patch, first because it's completely unrelated to Walloon or Picard,

OK. So another patch would be made for that.

> and second because I would never put graves on ij if I wished to stress this
> vowel, I would use acutes.

OK. On http://en.wikipedia.org/wiki/Dutch_language I read: “In the recent spelling reform, the accent grave was dropped as stress sign on short vowels in favour of the acute accent (e.g. 'wèl' was changed to 'wél').” But it has been used as a stress mark and persons who want to type “old” texts may want to type a j with grave. Why would you forbid that?

>  But yes, in theory you are correct: if á and à
> and é and è (and so on) exist, then also j́ and j̀ need to exist to make the
> range of stressed vowels complete.  But I think this is better put into a
> different patch -- it's hard enough to get the Xorg people to accept some
> simple compose additions that people actually want to use.

OK. Thx.
Comment 16 Jean-François Colson 2013-09-10 14:59:05 UTC
(In reply to comment #13)
> Created attachment 85561 [details] [review] [review]
> adds compose sequences for E and e with combining ring above

Where does the header come from?
I mean, when I used diff -u, I didn’t get any text similar to
From 8b4f5fa4a1f6d641b7a37a59edb8f17859040054 Mon Sep 17 00:00:00 2001
From: Benno Schulenberg <bensberg@justemail.net>
Date: Tue, 10 Sep 2013 13:58:45 +0200
Subject: [PATCH] =?UTF-8?q?nls:=20Adding=20compose=20sequences=20for=20E=CC=8A=20and=20e=CC=8A=20(with=20combining=20ring=20above).?=
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Where does that 8b4f5fa4a1f6d641b7a37a59edb8f17859040054 come from?
What does it mean?
Comment 17 Alan Coopersmith 2013-09-10 15:48:23 UTC
(In reply to comment #16)
> (In reply to comment #13)
> > Created attachment 85561 [details] [review] [review] [review]
> > adds compose sequences for E and e with combining ring above
> 
> Where does the header come from?

git format-patch or git send-email
http://www.x.org/wiki/Development/Documentation/SubmittingPatches/
Comment 18 Jean-François Colson 2013-09-10 16:22:58 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > (In reply to comment #13)
> > > Created attachment 85561 [details] [review] [review] [review] [review]
> > > adds compose sequences for E and e with combining ring above
> > 
> > Where does the header come from?
> 
> git format-patch or git send-email
> http://www.x.org/wiki/Development/Documentation/SubmittingPatches/

Thank you, but…

“We assume you have a git cloned repository…”
I don’t. Should I add one on my computer, on a server or anywhere else?
Should I type the commands on my computer, on a server or anywhere else?

“…and are familiar with making code changes and commits.”
I’m not. Where should I start? Does Xorg have a good tutorial about git commits anywhere?
Comment 19 Jean-François Colson 2013-09-10 16:26:27 UTC
Perhaps I’ll find answers to all my questions here: https://bugs.freedesktop.org/docs/en/html/using.html
Comment 20 Benno Schulenberg 2013-09-10 17:55:30 UTC
(In reply to comment #19)
> Perhaps I’ll find answers to all my questions here:
> https://bugs.freedesktop.org/docs/en/html/using.html

No.  Bugzilla has nothing to do with _making patches, it is for reporting bugs,
and for storing/discussing patches that fix those bugs.

If you had gone up one level from the Documentation page that Alan linked to,
you would have found http://www.x.org/wiki/Development/Documentation/ , and at the bottom of that a link to a "git" page, which suggests the "Everyday Git" guide at  https://www.kernel.org/pub/software/scm/git/docs/everyday.html

Now, please read, and save up your questions for another day.  :)

When you've installed git and have some idea of how to go about it, you do:

  git  clone  git://anongit.freedesktop.org/git/xorg/lib/libX11

That downloads five megabytes of stuff.  Enter the new subdir, and have a look at it with 'git log', and for more detail with 'git log -p --stat'.  When you want coloured diffs, have a look at 'git help config', search for "color.diff".
Comment 21 Benno Schulenberg 2013-09-10 18:21:27 UTC
(In reply to comment #15)
> > It will also fix the mistaken <O> <e> sequence to <o> <e>.
> 
> That wasn’t a mistake at all. That was intended to avoid a conflict with <o>
> <e> which is used for œ.

Oww... crap!  Whoops!  Eh... sorry!  :(

Weh...  That makes for ugly sequences.  The A and U use, besides the small o, also the asterisk for composing ring above, but I find that even more ugly.  Personally I would have chosen the zero to compose ring above, it somehow feels more "above" for me than O.  Adapted patch is coming up.

> persons who want to type “old” texts may want to
> type a j with grave. Why would you forbid that?

I have no intention of forbidding that.  :)  I just don't feel any inclination at the moment of going to the trouble of providing that possibility.  I can't even get my own desired <u> <a> for ă into the file.
Comment 22 Benno Schulenberg 2013-09-10 18:23:09 UTC
Created attachment 85580 [details] [review]
adds several sequences for E and e with combining ring above
Comment 23 Benno Schulenberg 2013-09-16 14:45:50 UTC
Created attachment 85917 [details] [review]
adds extensive sequences for E and e with combining ring above

I came across RFC 1345 (https://www.rfc-editor.org/rfc/rfc1345.txt), in which the character zero (after the letter) is proposed as the composing element for ring above.  So this more elaborate version of the patch adds also the postix <0>, ánd the postfix <O> and <o> sequences for composing E̊ and e̊.  What do you think?
Comment 24 Benno Schulenberg 2014-05-29 15:30:56 UTC
Created attachment 100116 [details] [review]
adds extensive sequences for E and e with combining ring above

Updated the patch for current git.
Comment 25 GitLab Migration User 2018-08-10 20:12:01 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/xorg/lib/libx11/issues/55.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.