Bug 32624 - [SNB GT2] Glean/'ARL test' fail for the first run
Summary: [SNB GT2] Glean/'ARL test' fail for the first run
Status: VERIFIED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium major
Assignee: haihao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-23 23:10 UTC by Yi Sun
Modified: 2012-09-25 02:20 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yi Sun 2010-12-23 23:10:03 UTC
System Environment:
--------------------------
Platform:    Hunronriver
Kernel_version:  (drm-intel-fixes)448f53a1ede54eb854d036abf54573281412d650
Libdrm:         (master)2.4.23-4-gbad5242a59aa8e31cf10749e2ac69b3c66ef7da0
Mesa:           (7.10)b7c187df9ac9bb778cf0f2abb3ad86775e42b07b
Xserver:       
(server-1.9-branch)xorg-server-1.9.3-9-gd819ff1cb521af77764af75e04645af4d4d06e3d
Xf86_video_intel: (master)2.13.902-9-g58d9912e447cf6e29b20747b5ed6ee595687ce8d

Bug detailed description:
-------------------------
The output is as following:

glean: brw_vs_emit.c:1113: get_reladdr_constant: Assertion `c->func.brw->intel.gen < 6' failed.

Reproduce steps:
-------------------------
PIGLIT_TEST='ARL test' bin/glean -t vertProg1 -o -r t
Comment 1 Wang Zhenyu 2010-12-27 21:58:35 UTC
Fix already on 7.10. Close.
Comment 2 Yi Sun 2010-12-29 17:17:12 UTC
On HunronRiver, when i run the case for the first time, the output is as following(one test fail). But if i run it again or more times, the case is passed. Until reboot the system, the failure appear again. 
The issue doesn't appear on SurgarBay.


vertProg1:  PASS rgba8, db, z24, s8, win+pmap, id 33
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, db, z24, s8, win+pmap, id 34
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, db, z24, s8, win+pmap, id 105
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, z24, s8, win+pmap, id 157
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, db, z24, s8, win+pmap, id 158
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, db, z24, s8, win+pmap, id 159
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, z24, s8, win+pmap, id 163
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, db, z24, s8, win+pmap, id 164
        45 tests passed, 0 tests failed.
FAILURE:
  Program: ARL test
  Expected color: 0.11, 0.22, 0.33, 0.44
  Observed color: 0.0509804, 0.105882, 0.156863, 1
vertProg1:  FAIL rgb8, db, z24, s8, accrgb16, win+pmap, slow, id 165
        44 tests passed, 1 tests failed.
vertProg1:  PASS rgba8, db, z24, s8, win+pmap, id 166
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, db, z24, s8, accrgba16, win+pmap, slow, id 167
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, z24, s8, win+pmap, id 171
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, db, z24, s8, win+pmap, id 172
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, db, z24, s8, win+pmap, id 173
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, z24, s8, win+pmap, id 177
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, db, z24, s8, win+pmap, id 178
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, db, z24, s8, win+pmap, id 179
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgb8, db, z24, s8, accrgb16, win+pmap, slow, id 180
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, db, z24, s8, win+pmap, id 181
        45 tests passed, 0 tests failed.
vertProg1:  PASS rgba8, db, z24, s8, accrgba16, win+pmap, slow, id 182
        45 tests passed, 0 tests failed.
Comment 3 fangxun 2011-03-07 05:33:16 UTC
Tested with latest code, this issue as sunyi described is still happens on our huronriver(rev08 and rev09) and SurgarBay(rev09 GT2). It passes on SurgarBay(rev09 GT1).
Comment 4 Gordon Jin 2011-03-07 17:04:20 UTC
So it happens on the 3 GT2 machines, but not the 1 GT1 machine.
Can developers confirm?
Comment 5 Eric Anholt 2011-04-29 16:17:16 UTC
Works fine for me on Mesa master (plus the glsl-vs-max-varyings fix), 8086:0126.
Comment 6 Eric Anholt 2011-06-28 12:13:34 UTC
Haven't seen it on either of the 2 GT2 machines I've used since my last comment.  Are you still seeing it?
Comment 7 Eric Anholt 2011-07-20 13:13:02 UTC
Can you test on your hardware with Mesa master?
Comment 8 Kenneth Graunke 2011-11-08 21:52:08 UTC
No response since March, and development hasn't seen this behavior.  Closing.  (Also, our primary development machines are all GT2s these days...)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.