Bug 32804 - [swrast] glean pixelFormats regression
[swrast] glean pixelFormats regression
Status: CLOSED FIXED
Product: Mesa
Classification: Unclassified
Component: Other
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Marek Olšák
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-03 13:54 UTC by Vinson Lee
Modified: 2011-01-09 00:38 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2011-01-03 13:54:57 UTC
mesa: 30fef21aa34667d332669f1445de74b49994eb0e (master)

glean pixelFormats now fails but previously passed.

$ glean -r results -t pixelFormats
pixelFormats failed at pixel (0,0), color channel 0:
  Expected: 0xff 0xff 0xff 0xff
  Found:    0xf0 0xf0 0xf0 0xff
  Format: GL_RGBA
  Type: GL_UNSIGNED_BYTE
  Internal Format: GL_LUMINANCE4_ALPHA4
  EnvMode: GL_REPLACE
pixelFormats failed at pixel (0,0), color channel 0:
  Expected: 0xff 0xff 0xff 0xff
  Found:    0xf0 0xf0 0xf0 0xff
  Format: GL_RGBA
  Type: GL_BYTE
  Internal Format: GL_LUMINANCE4_ALPHA4
  EnvMode: GL_REPLACE
...
Comment 1 Vinson Lee 2011-01-03 14:11:06 UTC
bae9d511f343c7bd5eb66d1d1d18d32b47e738e3 is the first bad commit
commit bae9d511f343c7bd5eb66d1d1d18d32b47e738e3
Author: Marek Olšák <maraeo@gmail.com>
Date:   Tue Dec 21 23:46:32 2010 +0100

    mesa: implement new texture format AL44
    
    Radeon GPUs can do this. R600 can even do render-to-texture.
    Packing and extracting aren't implemented, but we shouldn't hit them (I think).
    Tested with swrast, softpipe, and r300g.

:040000 040000 233f14a6fda6ac39e7a58db4e4aac427212b92d9 25ac51183d2f3395afd83a075edbc89e14eda5be M	src
bisect run success
Comment 2 Brian Paul 2011-01-03 16:18:54 UTC
Fixed with 7bd2c5d1f98d0cfcf896a58c3d66713165f6bedd
Comment 3 Marek Olšák 2011-01-08 13:43:48 UTC
Sorry I couldn't notice this regression because swrast fails glean/pixelFormats badly here:

pixelFormats:  FAIL rgba8, db, z24, s8, win+pmap, id 33
	4628 tests passed, 7204 tests failed.
Comment 4 Vinson Lee 2011-01-09 00:38:15 UTC
mesa: 90e29afcb62411b69d57dac76fe89c69c9936ed6 (master)

Verified fixed.