Bug 33185 - [RADEON:KMS:R300G] X crashes when kwin effects are turned on
[RADEON:KMS:R300G] X crashes when kwin effects are turned on
Status: RESOLVED WORKSFORME
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300
unspecified
x86 (IA32) Linux (All)
: medium critical
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-16 06:53 UTC by Wojciech Ryrych
Modified: 2011-03-25 15:02 UTC (History)
0 users

See Also:


Attachments
kWin backtrace (24.98 KB, text/plain)
2011-01-16 06:53 UTC, Wojciech Ryrych
Details
kWin backtrace (18.93 KB, text/plain)
2011-01-26 09:39 UTC, Wojciech Ryrych
Details
kWin backtrace #2 (25.59 KB, text/plain)
2011-02-11 02:13 UTC, Wojciech Ryrych
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Ryrych 2011-01-16 06:53:55 UTC
Created attachment 42100 [details]
kWin backtrace

Kubuntu 10.10, X, libs etc from xorg-edgers ppa.
With kWin effects Kubuntu is very unstable and crashes randomly.
Comment 1 Michel Dänzer 2011-01-17 02:44:48 UTC
Can you get another backtrace with /usr/lib/dri/r300_dri.so having debugging symbols?
Comment 2 Wojciech Ryrych 2011-01-17 09:08:32 UTC
(In reply to comment #1)
> Can you get another backtrace with /usr/lib/dri/r300_dri.so having debugging
> symbols?

do you mean I have to install debugging symbols when kWin crashes (in its dialogue window)? Is it sufficient?
Comment 3 Wojciech Ryrych 2011-01-23 06:58:19 UTC
bumb
Michel: can you help me? :)
Comment 4 Michel Dänzer 2011-01-24 02:47:57 UTC
(In reply to comment #2)
> do you mean I have to install debugging symbols when kWin crashes (in its
> dialogue window)? Is it sufficient?

I don't know if it's possible/sufficient at that point. Better install them before reproducing the problem.
Comment 5 George Kiagiadakis 2011-01-25 15:30:47 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Can you get another backtrace with /usr/lib/dri/r300_dri.so having debugging
> > symbols?
> 
> do you mean I have to install debugging symbols when kWin crashes (in its
> dialogue window)? Is it sufficient?

You can either click drkonqi's button and install them when the crash happens (if your distribution supports this), or install them manually after seeing the backtrace in drkonqi and then click the reload button to get a new backtrace, or just install them before reproducing the crash. In any case, they must be installed and a new backtrace needs to be generated after they have been installed. (All that of course implies that your distribution provides those symbols in some package).
Comment 6 Wojciech Ryrych 2011-01-26 09:39:53 UTC
Created attachment 42538 [details]
kWin backtrace

OK, I've installed debugging symbols so hope this backtrace is more helpful. :)
Comment 7 Wojciech Ryrych 2011-02-05 07:48:19 UTC
Do you know when it’s going to be fixed? Or which version is the target?
Comment 8 Marek Olšák 2011-02-10 18:20:02 UTC
Is this issue still present with the current Mesa master branch?
Comment 9 Wojciech Ryrych 2011-02-11 02:12:32 UTC
(In reply to comment #8)
> Is this issue still present with the current Mesa master branch?

I’m using packages from xorg-edgers and yesterday there was an update. I’ve got the following mesa packages installed:

* libglapi-mesa 7.11.0+git20110209.b6e3130a…
* liblu1-mesa 7.11.0+git20110209.b6e3130a…
* libgl1-mesa-dri 7.11.0+git20110209.b6e3130a…
* libgl1-mesa-glx 7.11.0+git20110209.b6e3130a…

Quick test and I’ve got no X crash but kWin does.
Comment 10 Wojciech Ryrych 2011-02-11 02:13:36 UTC
Created attachment 43244 [details]
kWin backtrace #2
Comment 11 Wojciech Ryrych 2011-02-11 02:18:27 UTC
Desktop Effects in KDE System Settings are behaving very weird and unstable. Once it tells me that effects can be turned on and the other times that can’t. For example just before now it told me that they can’t be and then they were on actually! After that kWin crashed. So I can say that no matter what option I choose: direct rendering, use vsync or disable functionality tests kWin crashes.
Comment 12 Marek Olšák 2011-02-22 08:16:55 UTC
(In reply to comment #10)
> Created an attachment (id=43244) [details]
> kWin backtrace #2

This backtrace doesn't make sense. There's a NULL pointer check in r300_buffer_create, so get_cs_handle shouldn't be called at all. Have you installed the driver properly?
Comment 13 Wojciech Ryrych 2011-02-23 03:01:42 UTC
> This backtrace doesn't make sense. There's a NULL pointer check in
> r300_buffer_create, so get_cs_handle shouldn't be called at all. Have you
> installed the driver properly?

Marek, as I said I have the driver installed from xorg-edgers ppa. I don’t compile it myself. This ppa is a snapshot from git and updates arrive fairly often. I’d like to help you writing good report but I can only tell that kWin crashes when I try to turn destop effects on.

I saw many similar problems to mine but in other bugzillas, be it KDE, Ubuntu and others. The problem is many people don’t decide to report their problems upstream, that is here, on freedesktop. I would also like to know if someone else has the same problem as I have.
Comment 14 Marek Olšák 2011-02-23 04:12:41 UTC
Alright, I missed that info, sorry. I tried kwin just recently and I didn't see any crashes.
Comment 15 Wojciech Ryrych 2011-03-25 12:22:04 UTC
(In reply to comment #14)
> Alright, I missed that info, sorry. I tried kwin just recently and I didn't see
> any crashes.

Hello again, Marek.


I’ve just tried out Desktop Effects. And … and it has turned out that they are working! So does even blur that didn’t!

Looking at your previous post I realized that you could have been surprised because Mesa you was talking about that is version from February 22nd is actually the version that I have now.

I don’t know why it did not work. Really. But now it is working.

Cool. Thank you very much guys!

One more thing I want to ask. Should I pin this package – leave it in the current version? I’d like to know if there will be any serious changes under the hood that might corrupt kWin.

Once again – thank you!
Comment 16 Marek Olšák 2011-03-25 15:02:43 UTC
If the package works for you and you don't demand any special features, I recommend not updating it. I am closing the bug now, thanks for the info.

It's Ubuntu people's problem. They should know that doing *monthly* updates of potentially-unstable code is not really useful to anyone. /rant