Bug 34061 - [SNB, IVB]Screen mess when running vdrift or padman
[SNB, IVB]Screen mess when running vdrift or padman
Status: VERIFIED WORKSFORME
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
All Linux (All)
: medium normal
Assigned To: Ian Romanick
libo
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-09 00:51 UTC by meng
Modified: 2012-02-23 01:58 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
A photo of screen mess (122.22 KB, image/jpeg)
2011-02-09 00:51 UTC, meng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description meng 2011-02-09 00:51:07 UTC
Created attachment 43153 [details]
A photo of screen  mess

System Environment:
--------------------------
Platform:           Huronriver
Libdrm:            (master)2.4.23-6-g550fe2ca3b29ad2191eab4fdfbed9ed21e25492d
Mesa:              (master)2a456dc123e8263de8e4666890a34f403faa9a39
Xserver:           (master)xorg-server-1.9.99.901-165-gbe3be7580b6f6fd2f7fa4d4abfe5e1ab19470223
Xf86_video_intel:  (master)2.14.0-15-ga5a1ab7bbc58ec884cd0b90fe7139f402291b92f
Cairo:             (master)a8e8d2aba811487dbb5b682c4f55065008e7ebbd
Kernel:            (drm-intel-next)1a3665c81df32b23c38d4ba8a74761551d5673b1

Bug detailed description:
-------------------------
Screen mess when running vdrift. It's kernel regression.Pls see attached photo.

Reproduce steps:
-------------------------
1.xinit&
2.vdrift
Comment 1 Chris Wilson 2011-02-09 01:08:40 UTC
Jesse, does this look familiar?
Comment 2 Jesse Barnes 2011-02-09 07:25:18 UTC
That does look a bit like the failure Michael was seeing; if it's a kernel regression what's the offending commit?
Comment 3 meng 2011-02-14 02:58:49 UTC
Screen mess when running vdrift only exists on Huronriver (VGA compatible
controlle:0126(rev 08)).In particular, it works fine in our new Huronriver(VGA
compatible controller: Intel Corporation Device 0116 (rev 09)) and Sugarbay.
.
Comment 4 meng 2011-03-07 05:48:34 UTC
The main aspect of screen mess is car mess in this bug.
1.Huron River(0126 rev08)could reproduce this bug easily.Usually,it appears within 30 seconds after the game start and exists until the game is over. The game lasts about two minutes.
2.Sugarbay and HuronRiver(0116 rev 09):The situations of this two SNB is  different from above Huron River(0126 rev08). Car mess may appear after the game begins and continue one to two seconds.Besides, in a game ,the time and the probability for its occurence is small(the probability may 1/10 or much more lower ). It is hard to reproduce.
For Huron River(0126 rev08),this bug is easy to be reproduce.However, the situation of the good commit which was figured out ago is similar to “Sugarbay and HuronRiver(0116 rev 09)”after being test again(car mess may appear,but the time and the probability of a game is a little larger than the other two machines ).After the mistake was found,I tried to find out the good commit of Huron River(0126 rev08),but before unstalbe_Kernel_37 I still didn't find it.
Comment 5 Jesse Barnes 2011-06-08 11:29:03 UTC
I think this one is fixed now?
Comment 6 meng 2011-06-09 00:50:45 UTC
Test on Huronriver, the problem still exists.
---------------------------------------------------
Libdrm:    (master)2.4.26
Mesa:      (master)ef59049c5242a1be7fa59a182d342191185dd62b
Xserver:	   (master)xorg-server-1.10.99.901-16-g21eec367d0d9c142458f973062e17add4f693033
Xf86_video_intel:(master)2.15.0-38-g790f90a277ff2a6fbb615b8cd3c06faa0d549c41
Cairo:     (master)27d26bb8b5552915a63f5e9d65597f0ab99102b3
Libva:     (master)2704b9983415b8646ef211cdaa730df2d7f4336f
Kernel:	   (drm-intel-next) da3cc9202697a44057c1bd3ad685689375f1fe0c
Comment 7 meng 2011-06-09 01:39:45 UTC
The phenomenon: flashing spots on car come out when running vdrift. When spots come out, maybe disappear soon, then come out again.It exists not only on HuronRiver(rev 08) but also on HuronRiver(rev 09).
Comment 8 meng 2011-06-09 01:48:44 UTC
There is the same problem on padman.
Comment 9 libo 2011-09-29 02:11:43 UTC
The problem is still existed in IVB and SNB platform.
Comment 10 Gordon Jin 2011-09-29 18:14:25 UTC
Ian, can you reproduce this?

I have concern for getting performance data with this bug existing.
Comment 11 Gordon Jin 2011-11-01 01:09:00 UTC
Ian?
Comment 12 Eric Anholt 2011-11-07 18:26:41 UTC
Proposed fix that may apply (there's alpha testing on some of that screenshot, but I'm not sure how the car is rendered):

http://lkml.indiana.edu/hypermail/linux/kernel/1111.0/02876.html
Comment 13 Eugeni Dodonov 2011-12-06 06:12:11 UTC
Gordon, does this still happens with latest 3.2 RC, or drm-intel-next branch?
Comment 14 libo 2012-01-12 00:45:05 UTC
The bug only exists when run vdrift on the SNB, and both exists when run padman and vdrift on IVB.   
(In reply to comment #13)
> Gordon, does this still happens with latest 3.2 RC, or drm-intel-next branch?
Comment 15 Kenneth Graunke 2012-01-25 02:12:42 UTC
The attached vdrift screenshot looks an awful lot like the Sandybridge clock gating bug Eric fixed in kernel 3.2.

I just tried World of Padman on Ivybridge and it looks fine.  Vdrift doesn't run due to #44957 (an application bug), so I didn't test that.

Closing this as WORKSFORME.  If you still see problems, please open separate bugs for each application.
Comment 16 Gordon Jin 2012-01-28 19:51:49 UTC
Li Bo, please verify.
Comment 17 libo 2012-02-23 01:58:57 UTC
padman has been fixed in both IVB and SNB. but vdrift still has this problem, not only  on  IVB and SNB, but also on other platforms.