Bug 34137 - Kernel null pointer dereference with 2.6.38_rc4, pageflip, Radeon 6310, KDE
Summary: Kernel null pointer dereference with 2.6.38_rc4, pageflip, Radeon 6310, KDE
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-10 07:47 UTC by Chí-Thanh Christopher Nguyễn
Modified: 2011-04-14 10:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
dmesg with BUG and call trace (69.08 KB, text/plain)
2011-02-10 07:47 UTC, Chí-Thanh Christopher Nguyễn
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chí-Thanh Christopher Nguyễn 2011-02-10 07:47:03 UTC
Created attachment 43206 [details]
dmesg with BUG and call trace

Using kernel 2.6.38_rc4, xf86-video-ati 6.14.0, Radeon 6310 (Zacate), KDE 4.4

When starting KDE the graphics will freeze before the desktop appears, possibly when kwin attempts to enable desktop effects. In dmesg, the following appears along with a call trace containing radeon_crtc_page_flip:

 [ 1297.514583] BUG: unable to handle kernel NULL pointer dereference at           (null)

Afterwards, the system must be rebooted to get the graphics back. Setting Option "EnablePageFlip" "false" in xorg.conf makes the problem go away.
Comment 2 Chí-Thanh Christopher Nguyễn 2011-03-11 04:26:36 UTC
Yes, thank you. With the patch the problem is fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.