Bug 3458 - Abort when started without IPv6 support
Summary: Abort when started without IPv6 support
Status: RESOLVED FIXED
Alias: None
Product: avahi
Classification: Unclassified
Component: libavahi-core (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Lennart Poettering
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-02 11:11 UTC by Ross Burton
Modified: 2006-01-09 14:27 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Ross Burton 2005-06-02 11:11:02 UTC
My LinkStation PPC device runs Debian, but the kernel doesn't suppotr IPv6.  If
I disable IPv6 in the config structure, I get this on startup:

** (process:4590): CRITICAL **: bind(): Operation not permitted
** ERROR **: file iface.c: line 438 (avahi_interface_monitor_sync): assertion
failed: (m)

Putting a break on g_logv gives this stack:

#1  0x0ff95640 in g_log () from /usr/lib/libglib-2.0.so.0
#2  0x10005d14 in avahi_netlink_new (context=0x10037a60, priority=-10,
groups=273, cb=0x10003bf8 <callback>,
    userdata=0x10038b28) at netlink.c:134
#3  0x1000461c in avahi_interface_monitor_new (s=0x100379a8) at iface.c:417
#4  0x1000a004 in avahi_server_new (c=0x0, sc=0x7ffff6b0, callback=0x10001644
<server_callback>,
    userdata=0x0) at server.c:1036
#5  0x10001dfc in main (argc=1, argv=0x7ffff784) at avahi-test.c:190

I believe the problem is that iface.c:417 specifies both IPV4 and IPV6 without
checking the configuration file.
Comment 1 Ross Burton 2005-06-02 11:31:41 UTC
Turns out I need to run avahi-test as root...

Odd.
Comment 2 Lennart Poettering 2005-06-02 14:26:25 UTC
Is the kernel that does not support IPv6 a 2.4 kernel? Some netlink operations
are priviliged in 2.4 but are not in 2.6. This may be the reason for your problem.
Comment 3 Ross Burton 2005-06-06 00:04:25 UTC
Yes, it's a 2.4 kernel.
Comment 4 Trent Lloyd 2005-10-21 22:04:18 UTC
lennart, ross, any progress on this? 
Comment 5 Lennart Poettering 2005-10-22 13:35:15 UTC
No, not from me.
Comment 6 Lennart Poettering 2006-01-10 09:27:56 UTC
I will close this now, as this bug is probably gone. 

If it isn't, feel free to reopen the bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.