Bug 34597 - [bisected piketon]oglc blend-constcolor and 7 draw-buffers2 subcases regressed
[bisected piketon]oglc blend-constcolor and 7 draw-buffers2 subcases regressed
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
All Linux (All)
: high major
Assigned To: Chris Wilson
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 01:01 UTC by fangxun
Modified: 2011-02-28 17:29 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fangxun 2011-02-23 01:01:46 UTC
System Environment:
--------------------------
Arch:           x86_64
Platform:       piketon 
Libdrm:         (master)2.4.23-14-ga697fb6acad7992c3d23bb6a663663694782eb7b
Mesa:           (master)94ccc31ba4f64ac480137fd90f1ded44d2072f6e
Xserver:      (master)xorg-server-1.9.99.902-3-g93a73
993708b1345c86ec3ec06b02ed236595673
Xf86_video_intel:  master)2.14.0-29-g9599fde65a0d8b7e7c85199346f7b620bdd8388d
Kernel: (drm-intel-next)f4166442e7533ca2668d639d939b1bbdb8e6b423


Bug detailed description:
-------------------------
This regression happens on piketon with mesa master branch. Bisect shows
aac120977d1ead319141d48d65c9bba626ec03b8 is first bad commit.
commit aac120977d1ead319141d48d65c9bba626ec03b8
Author:     Chris Wilson <chris@chris-wilson.co.uk>
AuthorDate: Sun Feb 20 13:23:47 2011 +0000
Commit:     Chris Wilson <chris@chris-wilson.co.uk>
CommitDate: Mon Feb 21 12:59:35 2011 +0000

    i965: Move repeat-instruction-suppression to batchbuffer core

    Move the tracking of the last emitted instructions into the core
    batchbuffer routines and take advantage of the shadow batch copy to
    avoid extra memory allocations and copies.
Comment 1 Chris Wilson 2011-02-23 01:06:27 UTC
Can you please retest with the fixes in 

commit 3377faffcdc7227bd27381894c87c7600547744f
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Tue Feb 22 11:18:25 2011 +0000

    i965: Zero the offset into the vbo when uploading non-interleaved
    
    Fixes regression from 559435d9152acc7162e4e60aae6591c7c6c8274b.
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>

before I start chasing this one done.
Comment 2 fangxun 2011-02-23 03:57:13 UTC
sorry, blend-separate is not regression. 

blend-constcolor and 7 draw-buffers2 subcases regressed due to commit aac120977d1ead319141d48d65c9bba626ec03b8.

And I retest these cases with 3377faffcdc7227bd27381894c87c7600547744f, the regression still happens.
Comment 3 Chris Wilson 2011-02-24 04:34:32 UTC
Can you add the oglc output like you did for bug 34603? That was most useful, thanks.
Comment 4 Chris Wilson 2011-02-24 05:01:40 UTC
commit f19439940c43aa9d937716c6f1ee70cc26799e08
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Feb 24 12:59:52 2011 +0000

    i965: Remember to pack the constant blend color as floats into the batch
    
    Fixes regression from aac120977d1ead319141d48d65c9bba626ec03b8.
    
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=34597
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Comment 5 fangxun 2011-02-28 17:29:54 UTC
Verified with mesa master commit ab824a0722d3a7ec14d559fc07d924fedf0534bc.