Bug 34893 - accountsservice ignores /etc/login.defs and has hard-coded DEFAULT_MINIMAL_UID
Summary: accountsservice ignores /etc/login.defs and has hard-coded DEFAULT_MINIMAL_UID
Status: RESOLVED FIXED
Alias: None
Product: accountsservice
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Matthias Clasen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-01 18:10 UTC by Benedikt Morbach
Modified: 2011-03-17 11:28 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description Benedikt Morbach 2011-03-01 18:10:34 UTC
Problem:
GDM/accountsservice shows system users / misses normal users.

Cause:
accountsservice has a hardcoded value (500) for MINIMAL_UID in src/daemon.c and does not respect the (SYS)_UID_(MIN|MAX) values from /etc/login.defs
This either leads to system users showing up e.g. in gdm or to normal users being missing (less likely), because on different distributions, UIDs for normal users start e.g. at 1000

Expected Behaviour:
It should either read /etc/login.defs
or provide an option to change MINIMAL_UID, at least at compile time

See also:
https://bugzilla.gnome.org/show_bug.cgi?id=623225
https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/427462
https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/459199
Comment 1 Ray Strode [halfline] 2011-03-17 11:28:50 UTC
Thanks, this should be covered by

http://cgit.freedesktop.org/accountsservice/commit/?id=fdb2cbeafce21c9b79f7617706360bc3a87d72f3


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.