Bug 3525 - Evolution crashes on startup
Summary: Evolution crashes on startup
Status: RESOLVED NOTOURBUG
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Havoc Pennington
QA Contact:
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-11 15:38 UTC by Daniel Stone
Modified: 2006-08-01 10:27 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Description FreeDesktop Bugzilla Database Corruption Fix User 2005-06-11 15:38:31 UTC
Evolution crashes on startup if a certain message is selected and the preview
pane is active. An example of a message that crashes evolution is here:

http://bugzilla.gnome.org/attachment.cgi?id=2&action=view

This is with dbus-0.23.4 from ubuntu hoary.

According to  Jeffrey Stedfast  the bug mentioned in the URL is not a gnome bug
but a DBUS bug. Therefore, I'm reporting it here.


Wouter
Comment 1 Colin Walters 2005-06-15 21:34:36 UTC
Er...need more details here.  That URL links to an email signature.  How exactly
can we reproduce this problem?
Comment 2 FreeDesktop Bugzilla Database Corruption Fix User 2005-06-16 00:18:04 UTC
hmm... Something went wrong while copying the attachment link I suppose. This is
the correct link.

https://bugzilla.ubuntu.com/attachment.cgi?id=2589
Comment 3 John (J5) Palmieri 2005-06-29 12:26:08 UTC
The actual e-mail is useless unless for some reason evolution is sending it over
the bus.  My only knowledge of dbus being used in Evolution is in the plugin
that sends signals over the bus when a mail has arrived.

What we need is a link to the actual bug report or a backtrace.

Found the ubuntu bug here:

https://bugzilla.ubuntu.com/show_bug.cgi?id=11413

The backtrace doesn't indicate d-bus.  I'll have to wait until gnome.org is back
up to check the upstream report.
Comment 4 John (J5) Palmieri 2005-07-02 15:18:33 UTC
Indeed it looks like the dbus plugin is failing in dbus_setup_with_g_main:

http://bugzilla.gnome.org/show_bug.cgi?id=306271

I don't know what it could be and is most likely a bug within evolution's
implementation.  It could be a threading issue.  Best bet is to make sure the
person who wrote the plugin sees the crash and can perhaps elaborate on what is
happening.

Other than that you could run evolution with DBUS_VERBOSE=1 (e.g. DBUS_VERBOSE=1
evolution &> evo.output) and attach the output to this report.
Comment 5 John (J5) Palmieri 2005-08-24 22:17:04 UTC
I haven't gotten any more information and belive this is being tackled upstream
in Evolution.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.