Bug 37091 - Typo in configure.ac
Typo in configure.ac
Product: udisks
Classification: Unclassified
Component: general
Other All
: medium normal
Assigned To: David Zeuthen (not reading bugmail)
Depends on:
  Show dependency treegraph
Reported: 2011-05-10 23:50 UTC by Ozan Çağlayan
Modified: 2012-03-31 14:25 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description Ozan Çağlayan 2011-05-10 23:50:01 UTC
With the below commit,

commit 90a5e6b6fd586119d17159d553e238e14fc44f9e
Author: Martin Pitt <martin.pitt@ubuntu.com>
Date:   Wed Mar 3 22:06:09 2010 +0100

    in maintainer mode, build with -Werror
    With --enable-maintainer-mode, or with --enable-strict, build with -Werror.

diff --git a/configure.ac b/configure.ac
index be9562c..d4c46a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,7 @@ AC_ARG_ENABLE(ansi,             [  --enable-ansi           enable -ansi -pedanti
 AC_ARG_ENABLE(verbose-mode,     [  --enable-verbose-mode   support verbose debug mode],enable_verbose_mode=$enableval,enable_verbose_mode=$USE_MAINTAINER_MODE)
 AC_ARG_ENABLE(man-pages,        [  --enable-man-pages      build manual pages],enable_man_pages=$enableval,enable_man_pages=yes)
 AC_ARG_ENABLE(profiling,        [  --enable-profiling      add tracing instrumentation for plot-timeline.py], enable_profiling=$enableval,enable_profiling=$USE_MAINTAINER_MODE)
++AC_ARG_ENABLE(strict,           [  --enable-strict         Enable strict compilation options], enable_strict=$enableval,enable_strict=$USE_MAINTAINER_MODE)

There's an extra faulty + in the line AC_ARG_ENABLE(strict
Comment 1 Nicolas Lécureuil 2012-03-31 14:25:36 UTC
fixed in commit 91405103e0267c73c76f44be5e1de7169884d8c6