Bug 37528 - vgaswitcheroo: support for mux-less hybrid laptops
vgaswitcheroo: support for mux-less hybrid laptops
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Radeon
unspecified
x86-64 (AMD64) Linux (All)
: medium enhancement
Assigned To: Default DRI bug account
:
: 39218 41340 41467 46270 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-23 23:44 UTC by eruditehermit
Modified: 2014-01-09 20:50 UTC (History)
6 users (show)

See Also:


Attachments
dmesg before echo DDIS > switch (181.08 KB, patch)
2011-05-23 23:44 UTC, eruditehermit
no flags Details | Splinter Review
dmesg after echo DDIS > switch (217.13 KB, patch)
2011-05-23 23:45 UTC, eruditehermit
no flags Details | Splinter Review
Xorg.0.log before echo DDIS > switch (26.96 KB, application/octet-stream)
2011-05-23 23:46 UTC, eruditehermit
no flags Details
Xorg.0.log after echo DDIS > switch (37.29 KB, application/octet-stream)
2011-05-23 23:46 UTC, eruditehermit
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description eruditehermit 2011-05-23 23:44:35 UTC
Created attachment 47090 [details] [review]
dmesg before echo DDIS > switch

When I try to switch to my radeon HD 6630 discrete GPU on my sandybridge Sony VAIO VPCSB from intel integrated GPU, I get a segmentation fault in X and even VT output to screen stops. When I ssh in from another computer and switch back to the intel GPU, my screen comes back and I can restart X and log in again.

Steps I performed to produce this:
1) make sure both intel and radeon kernel modules are loaded
2) echo DDIS > /sys/kernel/debug/vgaswitcheroo/switch
3) log out of X. At this point the screen is unresponsive and I cannot use the machine or log into X because it has segfaulted
4) ssh in from another computer
5) echo DIGD > /sys/kernel/debug/vgaswitcheroo/switch
7) switch to VT1 of first computer
8) login and type: sudo service gdm restart from first computer
9) log back into X on first computer
Comment 1 eruditehermit 2011-05-23 23:45:26 UTC
Created attachment 47091 [details] [review]
dmesg after echo DDIS > switch
Comment 2 eruditehermit 2011-05-23 23:46:07 UTC
Created attachment 47092 [details]
Xorg.0.log before echo DDIS > switch
Comment 3 eruditehermit 2011-05-23 23:46:41 UTC
Created attachment 47093 [details]
Xorg.0.log after echo DDIS > switch
Comment 4 eruditehermit 2011-05-23 23:50:29 UTC
My setup is: 
Ubuntu 11.04
kernel 2.6.39 final
Xorg 7.6 
xserver 1.10.1+git20110429
radeon 6.14.99+git20110515
Comment 5 Alex Deucher 2011-10-05 06:08:50 UTC
You have a muxless laptop which means the discrete card is not connected to any
displays.  You won't be able to use the discrete card until the xserver gets
the ability to decouple rendering and display (i.e., rendering with one GPU,
displaying with another).  It's a huge amount of work and won't be supported
any time some.
Comment 6 Alex Deucher 2011-10-05 06:32:57 UTC
*** Bug 41340 has been marked as a duplicate of this bug. ***
Comment 7 Alex Deucher 2011-10-05 06:33:14 UTC
*** Bug 41467 has been marked as a duplicate of this bug. ***
Comment 8 Oleg German 2011-10-21 03:31:17 UTC
*** Bug 39218 has been marked as a duplicate of this bug. ***
Comment 9 Alex Deucher 2012-02-20 07:17:54 UTC
*** Bug 46270 has been marked as a duplicate of this bug. ***
Comment 10 Alex Deucher 2014-01-09 20:50:26 UTC
This is supported with xserver 1.14 and newer.