Can you consider changing the pkcon get-updates command to pkcon list-updates in a new major relase, because get-updates sounds more like the updates will be downloaded. And list-updates would be more in line with for example pkcon repo-list.
pkcon is really just a thin wrapper around the PackageKit DBus interface. GetUpdates is the DBUS name, so get-updates is the pkcon name. pkcon isn't really designed to be used by end users, users should be using the GUI tools.