Bug 38711 - Corruption in KDE since xorg-server-1.10 with the radeon driver
Corruption in KDE since xorg-server-1.10 with the radeon driver
Status: RESOLVED DUPLICATE of bug 31017
Product: xorg
Classification: Unclassified
Component: Driver/Radeon
unspecified
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: xf86-video-ati maintainers
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-27 05:20 UTC by boris64
Modified: 2011-07-02 23:17 UTC (History)
0 users

See Also:


Attachments
dmesg (56.12 KB, text/plain)
2011-06-27 05:20 UTC, boris64
no flags Details
lscpi -v (10.82 KB, text/plain)
2011-06-27 05:21 UTC, boris64
no flags Details
Xorg.0.log (55.98 KB, text/x-log)
2011-06-27 05:21 UTC, boris64
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description boris64 2011-06-27 05:20:45 UTC
Created attachment 48460 [details]
dmesg

Hello folks, 

since i installed xorg-server-1.10 i see lots of graphical corruptions
in menus and on KDE logout. I couldn't get these errors on screenshot,
so i made 2 videos with a digital camera.
I'm not sure if bugzilla will let me attach those here because of 
the file size (8+12MB), so i uploaded them to my webspace here:

-> http://boris64.net/v2005/files/linux/bugreports/MVI_1856.AVI
(menu corruption)

-> http://boris64.net/v2005/files/linux/bugreports/MVI_1858.AVI
(corruption on logout)

Downgrading to xorg-server-1.9.5 made the issues go away.

I'm using normal EXA acceleration, xf86-video-ati/libdrm/mesa from git (latest).
If anything else is needed, tell me what info/log you need.

Thank you!
Comment 1 boris64 2011-06-27 05:21:08 UTC
Created attachment 48461 [details]
lscpi -v
Comment 2 boris64 2011-06-27 05:21:57 UTC
Created attachment 48462 [details]
Xorg.0.log
Comment 3 boris64 2011-06-27 05:24:07 UTC
This still occurs with xorg-server-1.10.2
Comment 4 Alex Deucher 2011-06-27 06:28:51 UTC
Looks like a duplicate of bug 34427
Comment 5 boris64 2011-06-27 06:51:30 UTC
yeah, it looks like the attached patch
-> https://bugs.freedesktop.org/attachment.cgi?id=43859
fixes the menu corruption for me. I think this report can
be marked as dupe. Hopefully this patch will make into
xorg-server soon as i'm seeing this on 3(!) computers with
radeon graphic cards.
Comment 6 boris64 2011-06-27 06:58:51 UTC
I still see little issues from time to time while watching
tv in kaffeine (switching from fullscreen to window mode)
and on a menu sidebar in KDE, so this patch is advancing 
the situation but is not a 100% fix.
Comment 7 boris64 2011-06-27 06:59:37 UTC

*** This bug has been marked as a duplicate of bug 34427 ***
Comment 8 Jeremy Huddleston 2011-07-02 23:17:57 UTC

*** This bug has been marked as a duplicate of bug 31017 ***