Bug 39 - some fonts now don't get served by fontconfig 1.0.2
Summary: some fonts now don't get served by fontconfig 1.0.2
Status: RESOLVED FIXED
Alias: None
Product: fontconfig
Classification: Unclassified
Component: fc-cache (show other bugs)
Version: 2.1
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Keith Packard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-02-28 02:49 UTC by Jeremy Huddleston Sequoia
Modified: 2003-02-28 16:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Font file causing problems (187.95 KB, application/octet-stream)
2003-02-28 02:50 UTC, Jeremy Huddleston Sequoia
Details

Description Jeremy Huddleston Sequoia 2003-02-28 02:49:41 UTC
The console8x16.pcf font that comes with KDE 3.x does not seem to work with 
the fontconfig that comes with XFree86-4.3.  It worked previously with the 
fontconfig that I compiled and installed over XFree86 4.2 with a tarball from your 
website. 
 
--- 
/opt/kde/share/fonts $ fc-list | grep console 
console8x16:style=Regular 
console8x8:style=Regular 
 
/opt/kde/share/fonts $ fc-list --version 
fontconfig version 1.0.1 
 
/opt/kde/share/fonts $ ls 
9x15.pcf  console8x16.pcf  console8x8.pcf  fonts.cache-1  fonts.dir  override/ 
--- 
/opt/kde-3/share/fonts $ fc-list | grep console 
console8x8:style=Regular 
 
/opt/kde-3/share/fonts $ fc-list --version 
fontconfig version 1.0.2 
 
/opt/kde-3/share/fonts $ ls 
9x15.pcf  console8x16.pcf  console8x8.pcf  fonts.cache-1  fonts.dir  fonts.scale  
override/
Comment 1 Jeremy Huddleston Sequoia 2003-02-28 02:50:42 UTC
Created attachment 27 [details]
Font file causing problems
Comment 2 Jeremy Huddleston Sequoia 2003-02-28 02:52:13 UTC
I don't believe it is the cause of the problem, but I thought I'd mention that I am 
used gcc 3.2.2 to compile XFree86 4.3 (and hence fontconfig 1.0.2), and I used 
gcc 3.2.1 (or maybe it was just 3.2) to compile fontconfig 1.0.1 
Comment 3 Keith Packard 2003-02-28 22:01:06 UTC
It's working for me now; I suspect this problem was caused by either the cache
file corruptions or the weird double/integer matching problem.  Feel free to
reopen if it's still busted for you and we'll have another go at figuring where
the problem lies.
Comment 4 Jeremy Huddleston Sequoia 2003-03-01 02:33:57 UTC
Ok, I kinda traced the problem.  The libfreetype that comes with X11R6 4.3
causes fc-cache to not work with this font.  When I removed the freetype libs
that X installed and went back to the other ones I have installed (2.1.3),
fc-cache works with this font.  By "works" I mean 'fc-cache -f -v' reports 3
fonts in /opt/kde/share/fonts rather than just 2.

What freetype library were you using when you verified that it did work for you?
Comment 5 Keith Packard 2003-03-01 09:55:27 UTC
Yes, I'm also using freetype 2.1.3.  The version in XFree86 CVS is ancient.
Comment 6 Jeremy Huddleston Sequoia 2003-03-01 11:14:56 UTC
Ok, well you might want to be aware of this problem with 2.1.1 (I believe that'e
the freetype version that comes with X), and hopefully you can put some pressure
to update the freetype in the XFree86 cvs to fix this in XFree86 4.3.1.

Thanks,
Jeremy


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.