Bug 39541 - [IvyBridge]GL screen savers cause screen blank and exit abnormally
[IvyBridge]GL screen savers cause screen blank and exit abnormally
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
git
x86 (IA32) Linux (All)
: high major
Assigned To: Kenneth Graunke
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-26 02:08 UTC by Ouping Zhang
Modified: 2011-11-07 18:57 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ouping Zhang 2011-07-26 02:08:10 UTC
System Environment:
--------------------------
Kernel: (drm-intel-fixes)7c9017e5b77118439952fe8dc22809bae4fae4b6
Libdrm:         (master)2.4.26-2-gce317a6d09bb93cff73703b06e5a5bc3cc0b1c6a
Mesa:           (7.11)b305c956be3fa27467ecbc379de2352926a554d0
Xserver:        (server-1.10-branch)xorg-server-1.10.3-12-ga0b8dacbc016e38c92300ed421850e11848b8454
Xf86_video_intel:  (master)2.15.0-205-g6dbbb74bde034f5f00aee0396ccd1e03a6625fbd

Bug detailed description:
-------------------------
run GL screen savers, the screen blank and it exited abnormally. But system is alive. refer to bug 38392, when running GL screen savers cause system hang, but the screen isn't blank.
by the way, GL screen savers can run well on sandy bridge platform.
Comment 1 Eugeni Dodonov 2011-09-23 14:24:34 UTC
I could not reproduce it on IVB today, could you check if it is still happens now?

Thanks!
Comment 2 Ouping Zhang 2011-09-26 02:17:09 UTC
System Environment:
--------------------------
Kernel: (drm-intel-next)64a742fac3a22f57303d8f1b7e347350a1c48254
Libdrm: (master)2.4.26-9-gcfee5218b17a2741e5519ed44091171e01f0dbb2
Mesa:   (master)06ae4a62b1b3c668a5b50661df25d87f8c2679ef
Xserver: (master)xorg-server-1.11.0-49-g7fb4bef0394a5d09680985d34bce8252b61493cb
Xf86_video_intel: (master)2.16.0-83-g6bbb88af096e054877409a54d0e0a4ccf5ee317e

After validation, the issue can't be reproduced on IVB, and xscreensaver run well by i965_dri.so
(In reply to comment #1)
> I could not reproduce it on IVB today, could you check if it is still happens
> now?
> Thanks!
Comment 3 Chris Wilson 2011-09-26 02:31:46 UTC
Let's treat this as closed and move on to the next. Thanks.
Comment 4 fangxun 2011-11-07 18:57:51 UTC
Verified on ivybridge with following commit:
Libdrm:         (master)2.4.27-1-g961bf9b5c2866ccb4fedf2b45b29fb688519d0db
Mesa:           (7.11)4464ee1a9aa3745109cee23531e3fb2323234d07
Xserver:       (server-1.11-branch)xorg-server-1.11.1
Xf86_video_intel: (master)2.16.901-24-g42e2036cda6b76f2b64e28a81bdaa661e4cbffa5