Bug 39858 - result of do_service_reload_test() is ignored
Summary: result of do_service_reload_test() is ignored
Status: RESOLVED MOVED
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: 1.5
Hardware: All All
: medium normal
Assignee: D-Bus Maintainers
QA Contact: D-Bus Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-05 05:36 UTC by Simon McVittie
Modified: 2018-10-12 21:12 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon McVittie 2011-08-05 05:36:45 UTC
>  if (!do_service_reload_test (&directory, FALSE))
>    ; /* Do nothing? */

This is not how regression tests work. :-)

I'd just make it fail on failure, but presumably there's some reason why it's done like this - is reloading platform-specific, perhaps? (If it is, then we should assert that it works on at least those platforms where we expect it to work.)
Comment 1 Simon McVittie 2017-02-20 16:25:30 UTC
(In reply to Simon McVittie from comment #0)
> >  if (!do_service_reload_test (&directory, FALSE))
> >    ; /* Do nothing? */
> 
> This is not how regression tests work. :-)
> 
> I'd just make it fail on failure, but presumably there's some reason why
> it's done like this - is reloading platform-specific, perhaps?

I think this might actually be a symptom of many of the "embedded tests" having this weird tristate behaviour to support the OOM testing:

* on success, return TRUE
* on failure that is due to running out of memory, return FALSE
* on other failure, _dbus_warn(), and immediately die with abort() because
  we configured those warnings to be fatal

At the very least this deserves some better comments.
Comment 2 GitLab Migration User 2018-10-12 21:12:30 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/dbus/dbus/issues/54.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.