Bug 39902 - R600g Evergreen: GPU lockup after launch of Bioshock
Summary: R600g Evergreen: GPU lockup after launch of Bioshock
Status: RESOLVED WORKSFORME
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-07 08:36 UTC by russianneuromancer
Modified: 2014-10-31 12:48 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Example of error message (3.34 KB, text/plain)
2011-08-09 21:13 UTC, russianneuromancer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description russianneuromancer 2011-08-07 08:36:26 UTC
Ubuntu 11.04, Linux 3.0.1, Mesa 7.12-devel and R600g from xorg-edgers PPA
(version of Mesa and R600g is git20110801). GPU lockup after splashscreen of StarCraft II (under WINE 1.3.26; problem doesn't reproduced with fglrx). Call trace attached. Xorg.log, dmesg and glxinfo output available here: https://bugs.freedesktop.org/show_bug.cgi?id=39897
Demo version of StarCraft II available here: http://www.starcraft2free.net/
Comment 1 Sven Arvidsson 2011-08-07 09:03:03 UTC
The SC2 demo has been working fine on r600g and Evergreen for me, so this might be a regression. 

You also need to make sure you're really using r600g if you're running 32-bit apps on a 64-bit problem, not doing so seems to be a common problem. Set LIBGL_DEBUG=verbose and check the output.
Comment 2 russianneuromancer 2011-08-09 21:12:11 UTC
You was right, there are probably problem with packaging of x86_64 of the driver.
https://bugs.freedesktop.org/show_bug.cgi?id=39897#c12
I can not reproduce StarCraft II GPU lockup on pure x86 setup. Works fine on low settings by the way.

But now I have another lockup-problem when I try to launch Bioshock or Metro 2033. 
How to reproduce:
1. Install Bioshock demo: http://www.gamefront.com/files/8363410
2. Launch Bioshock. Wait few seconds.
3. Switch to any other text console, and after that switch back to graphics console.
So now you should able to get GPU lockup. Log attached.
Comment 3 russianneuromancer 2011-08-09 21:13:02 UTC
Created attachment 50086 [details]
Example of error message
Comment 4 Sven Arvidsson 2011-08-10 03:27:07 UTC
Bioshock has been working for me in the past (on Evergreen), so this could be a regression. Specifically I was using git 2fe39b46e73aea37152777fe11d489e0b1bc3f92 and Wine 1.3.22. I will try it again when I have more time.

Keep in mind that to get the game running you need to revert commit 6a35cbb656e0f8a2479a63eadefb1ab85f42d490  to work around bug 38501.

Also, I think developers prefer if you file new and separate bug reports for issues with different games. It could be that the GPU hangs you describe all come from the same bug, but it could also be different problems all showing up in the same way.
Comment 5 Mike Mestnik 2012-04-29 08:46:43 UTC
I get a vary similar lockup, however my applications doesn't generate a trace. 
Try getting an apitrace.
Comment 6 David Heidelberg (okias) 2014-10-31 12:06:21 UTC
Is this issue from 2011 still valid?

SC2 and Bioshock work without any lookups (Kernel 3.14 - 3.16, Mesa-git) on HD 6550D (Evergreen, r600g)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.