Bug 41142 - [PATCH] mount fails on Alpine Linux due to uhelper=udisks mount option
[PATCH] mount fails on Alpine Linux due to uhelper=udisks mount option
Status: RESOLVED NOTOURBUG
Product: udisks
Classification: Unclassified
Component: operations
unspecified
Other Linux (All)
: medium normal
Assigned To: David Zeuthen (not reading bugmail)
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-23 02:09 UTC by Natanael Copa
Modified: 2011-09-23 06:43 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
udisks-uhelper.patch (392 bytes, patch)
2011-09-23 02:10 UTC, Natanael Copa
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Natanael Copa 2011-09-23 02:09:48 UTC
Busybox mount does not support the "uhelper=udisks" mount option and thus mount fails unless util-linux's mount is installed.

Looking at util-linux's mount/umount sources, it appears that this option does absolutely nothing useful nowdays, so rather than adding code doing nothing to busybox mount, I'd prefer udisk not append it.

Patch is tested on Alpine Linux and appears to work.

Thanks.
Comment 1 Natanael Copa 2011-09-23 02:10:51 UTC
Created attachment 51536 [details] [review]
udisks-uhelper.patch
Comment 2 David Zeuthen (not reading bugmail) 2011-09-23 06:43:36 UTC
(In reply to comment #0)
> Busybox mount does not support the "uhelper=udisks" mount option and thus mount
> fails unless util-linux's mount is installed.
> 
> Looking at util-linux's mount/umount sources, it appears that this option does
> absolutely nothing useful nowdays, so rather than adding code doing nothing to
> busybox mount, I'd prefer udisk not append it.

You are wrong - it absolutely does something useful these days (check the umount man page from recent util-linux).