Bug 41420 - [UPSTREAM REPOST] radeon driver power management is very bad: GPU always runs at maximum clock speed
Summary: [UPSTREAM REPOST] radeon driver power management is very bad: GPU always runs...
Status: RESOLVED INVALID
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: All All
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-03 08:49 UTC by Hans Bakker
Modified: 2016-02-26 06:13 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Bakker 2011-10-03 08:49:39 UTC
[This is not my own bug, but I decided that it would be better to repost it upstream from https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/825989. I have the same problem with my laptop GPU.]

The clock frequency of the GPU is set to maximum by default and it is never throttled back. This leads to a laptop battery that is drained quickly, an unneccesary amount of heat produced, an annoying fan, etc etc.

Users can set the frequency through the command line like with 
echo dynpm > /sys/class/drm/card0/device/power_method
but most users don't know about this.
Comment 1 Tomas Pospisek 2013-07-22 14:31:45 UTC
Does this change anything?: http://www.botchco.com/agd5f/?p=57
Available in kernel 3.11
Comment 2 Christopher M. Penalver 2016-02-26 06:13:10 UTC
Fix released downstream.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.