Bug 43829 - Resuming my AMD A4-3300 based laptop leaves the screen black
Summary: Resuming my AMD A4-3300 based laptop leaves the screen black
Status: RESOLVED DUPLICATE of bug 42960
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 49281 53657 54484 61470 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-14 07:27 UTC by Zoltán Böszörményi
Modified: 2014-04-03 20:01 UTC (History)
14 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg showing suspend/resume (102.91 KB, text/x-log)
2011-12-14 07:27 UTC, Zoltán Böszörményi
no flags Details
difference of `radeontool regmatch \*` from before and after suspend (2.20 KB, text/plain)
2012-01-05 17:21 UTC, Joshua Roys
no flags Details
difference of `radeonreg regs dce4` from before and after suspend (6.65 KB, text/plain)
2012-01-08 11:02 UTC, Joshua Roys
no flags Details
testing patch (603 bytes, patch)
2012-09-16 16:10 UTC, Alex Deucher
no flags Details | Splinter Review
t525-dmesg-patch-bug43829 (123.92 KB, text/plain)
2012-09-16 17:23 UTC, Helge Bahmann
no flags Details
a10-4600m_lspci (2.32 KB, text/plain)
2013-01-18 08:05 UTC, Nickolay
no flags Details
a10-4600m dmesg (66.78 KB, text/plain)
2013-01-18 08:06 UTC, Nickolay
no flags Details
possible fix (4.40 KB, patch)
2013-07-11 20:52 UTC, Alex Deucher
no flags Details | Splinter Review
possible fix 1/2 (2.86 KB, patch)
2013-08-19 17:21 UTC, Alex Deucher
no flags Details | Splinter Review
possible fix 2/2 (3.00 KB, patch)
2013-08-19 17:21 UTC, Alex Deucher
no flags Details | Splinter Review
dmesg+Xorg.0.log (35.85 KB, application/zip)
2013-09-12 06:29 UTC, Jose P.
no flags Details
dmesg, xorg (50.98 KB, text/plain)
2013-09-17 23:24 UTC, Jose P.
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Böszörményi 2011-12-14 07:27:01 UTC
Created attachment 54422 [details]
dmesg showing suspend/resume

I have installed Fedora 16 on my new ASUS K53TA laptop that has these devices:

# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Complex
00:01.0 VGA compatible controller: ATI Technologies Inc Device 9648
00:01.1 Audio device: ATI Technologies Inc Device 1714
00:02.0 PCI bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Port
00:04.0 PCI bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Port
00:05.0 PCI bridge: Advanced Micro Devices [AMD] Family 12h Processor Root Port
00:10.0 USB controller: Advanced Micro Devices [AMD] Hudson USB XHCI Controller (rev 03)
00:11.0 SATA controller: Advanced Micro Devices [AMD] Hudson SATA Controller [AHCI mode] (rev 40)
00:12.0 USB controller: Advanced Micro Devices [AMD] Hudson USB OHCI Controller (rev 11)
00:12.2 USB controller: Advanced Micro Devices [AMD] Hudson USB EHCI Controller (rev 11)
00:14.0 SMBus: Advanced Micro Devices [AMD] Hudson SMBus Controller (rev 13)
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] Hudson LPC Bridge (rev 11)
00:14.4 PCI bridge: Advanced Micro Devices [AMD] Hudson PCI Bridge (rev 40)
00:14.7 SD Host controller: Advanced Micro Devices [AMD] Hudson SD Flash Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 0 (rev 43)
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 1
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 2
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 3
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 4
00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 6
00:18.6 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 5
00:18.7 Host bridge: Advanced Micro Devices [AMD] Family 12h/14h Processor Function 7
01:00.0 VGA compatible controller: ATI Technologies Inc Whistler [AMD Radeon HD 6600M Series] (rev ff)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

I had to install kernel-3.2.0-0.rc5.git1.1.fc17.x86_64 from Rawhide to make KMS work on the integrated video.

I tried suspend/resume by closing the lid, suspend worked. Resume woke up the
machine but left the screen black. dmesg for the suspend/resume is attached.
Comment 1 Joshua Roys 2012-01-05 17:21:16 UTC
Created attachment 55194 [details]
difference of `radeontool regmatch \*` from before and after suspend

HP G4-1215DX with an A4-3300 APU here.  Everything comes back but the display on a resume from a suspend.  I can ssh into the machine and get any kind of debugging info needed.
Comment 2 Joshua Roys 2012-01-08 11:02:35 UTC
Created attachment 55303 [details]
difference of `radeonreg regs dce4` from before and after suspend

I have the full before and after dumps still if you need them also.
Comment 3 Alex Deucher 2012-01-11 14:16:55 UTC
Do these patches help?
http://people.freedesktop.org/~agd5f/dce_fixes/
Comment 4 Alex Deucher 2012-01-11 14:21:05 UTC
against drm-next or Linus' git.
Comment 5 Joshua Roys 2012-01-12 14:32:43 UTC
No- these patches leave my screen dark after KMS kicks in.
Comment 6 Zoltán Böszörményi 2012-01-14 19:14:30 UTC
Same for me - black screen.
Comment 7 Alex Deucher 2012-04-30 05:26:56 UTC
*** Bug 49281 has been marked as a duplicate of this bug. ***
Comment 8 Alex Deucher 2012-08-17 21:08:36 UTC
*** Bug 53657 has been marked as a duplicate of this bug. ***
Comment 9 Alex Deucher 2012-09-04 13:07:53 UTC
*** Bug 54484 has been marked as a duplicate of this bug. ***
Comment 10 Alex Deucher 2012-09-14 21:12:11 UTC
This should be fixed in my drm-next-3.7-wip branch:
http://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-next-3.7-wip
Comment 11 Helge Bahmann 2012-09-16 16:00:11 UTC
(In reply to comment #10)
> This should be fixed in my drm-next-3.7-wip branch:
> http://cgit.freedesktop.org/~agd5f/linux/log/?h=drm-next-3.7-wip

Just tried on Thinkpad E525 (see bug #54484), and it does *not* fix the issue ( it does however also not wedge the system as 3.6-rc3 did, in case you want would like any data collected or experiments performed).
Comment 12 Alex Deucher 2012-09-16 16:10:44 UTC
Created attachment 67249 [details] [review]
testing patch

If my 3.7 branch by itself doesn't work, does this patch on top of my 3.7 branch help?  Please attach the output of dmesg after resume with this patch applied.
Comment 13 Helge Bahmann 2012-09-16 17:23:37 UTC
Created attachment 67252 [details]
t525-dmesg-patch-bug43829

(In reply to comment #12)
> Created attachment 67249 [details] [review] [review]
> testing patch
> 
> If my 3.7 branch by itself doesn't work, does this patch on top of my 3.7
> branch help?  Please attach the output of dmesg after resume with this patch
> applied.

attached (the added DRM_INFO yields "bl_level: 0xff" )

as an additional experiment, I used "kexec" after suspending to reboot the same kernel and let the radeon driver do a full reinitialization -- but even that fails to bring the display back to life :(

Anything further I can do?
Comment 14 LRN 2012-09-24 20:19:42 UTC
I seem to be having this issue with A6-4400M (at least symptoms are all the same).

At first i thought that it's the same issue as #52256, but apparently it is not so simple.

I've tried merging http://cgit.freedesktop.org/~agd5f/linux/commit/?h=drm-next-3.7-wip&id=c49170742d6928b16fb3839b47a94cc41630dbe0 into current kernel master HEAD (it had 1 merge conflict, resolved it by sticking to the branch being merged in) and compiling&installing the resulting kernel - no luck.

Should i try attachment 67249 [details] [review] too and post the results?
Comment 15 Florian Mickler 2012-10-15 20:52:42 UTC
A patch referencing this bug report has been merged in Linux v3.7-rc1:

commit bced76f27165ca7733437715185c3a1aa526f7a1
Author: Alex Deucher <alexander.deucher@amd.com>
Date:   Fri Sep 14 09:45:50 2012 -0400

    drm/radeon: restore backlight level on resume
Comment 16 Helge Bahmann 2012-10-16 12:46:52 UTC
(In reply to comment #15)
> A patch referencing this bug report has been merged in Linux v3.7-rc1:
> 
> commit bced76f27165ca7733437715185c3a1aa526f7a1
> Author: Alex Deucher <alexander.deucher@amd.com>
> Date:   Fri Sep 14 09:45:50 2012 -0400
> 
>     drm/radeon: restore backlight level on resume

appears to be the same patch as mentioned in comment #10, and (at least for me) still does not fix the issue
Comment 17 Kristian Klausen 2012-12-28 11:25:37 UTC
(In reply to comment #16)
> (In reply to comment #15)
> > A patch referencing this bug report has been merged in Linux v3.7-rc1:
> > 
> > commit bced76f27165ca7733437715185c3a1aa526f7a1
> > Author: Alex Deucher <alexander.deucher@amd.com>
> > Date:   Fri Sep 14 09:45:50 2012 -0400
> > 
> >     drm/radeon: restore backlight level on resume
> 
> appears to be the same patch as mentioned in comment #10, and (at least for
> me) still does not fix the issue

I have think i have same problem with a Radeon HD 6520G (AMD A6-3410MX), it have "nothing" with backlight to do, if i use a flashlight i can see the screen is 100% off.
Comment 18 Nickolay 2013-01-18 08:02:43 UTC
I have the same problem with HP Pavilion g6-2137sr laptop with A10-4600M APU. I've attached dmesg and lspci output of my laptop.
Comment 19 Nickolay 2013-01-18 08:05:57 UTC
Created attachment 73234 [details]
a10-4600m_lspci
Comment 20 Nickolay 2013-01-18 08:06:32 UTC
Created attachment 73235 [details]
a10-4600m dmesg
Comment 21 Nickolay 2013-01-18 08:09:12 UTC
(In reply to comment #18)
> I have the same problem with HP Pavilion g6-2137sr laptop with A10-4600M
> APU. I've attached dmesg and lspci output of my laptop.
P.S. Kernel version 3.7.3
Comment 22 LRN 2013-02-28 19:16:47 UTC
Still getting this.
Linux kernel 3.8.0 (9e2d59ad580d590134285f361a0e80f0e98c0207)
xf86-video-ati 343b01c9bf35b125cd0c3df8db7c01a5fb227bda
Comment 23 Dennis Nezic 2013-05-03 15:42:02 UTC
I had a similar problem with my x700 (rv410) radeon, and fixed it with:
  radeontool light off 
  radeonreg regset 0x00000284 0x1bd34208 
  radeonreg regset 0x000002d0 0x003c00a1 
  radeonreg regset CL:03 0x001c0007 
  radeonreg regset CL:04 0x0002004a 
  radeonreg regset CL:05 0x0002004a 
  radeonreg regset CL:06 0x0002004a 
  radeontool light on

Have you guys tried the radeontool light thingy?
Comment 24 Alex Deucher 2013-05-03 16:01:41 UTC
(In reply to comment #23)
> I had a similar problem with my x700 (rv410) radeon, and fixed it with:
>   radeontool light off 
>   radeonreg regset 0x00000284 0x1bd34208 
>   radeonreg regset 0x000002d0 0x003c00a1 
>   radeonreg regset CL:03 0x001c0007 
>   radeonreg regset CL:04 0x0002004a 
>   radeonreg regset CL:05 0x0002004a 
>   radeonreg regset CL:06 0x0002004a 
>   radeontool light on
> 
> Have you guys tried the radeontool light thingy?

Please file a separate bug for this, this should be handled properly in the driver.  These registers are only relevant for very old radeons so they don't apply to newer asics.
Comment 25 Alex Deucher 2013-07-11 20:49:30 UTC
*** Bug 61470 has been marked as a duplicate of this bug. ***
Comment 26 Alex Deucher 2013-07-11 20:52:02 UTC
Created attachment 82347 [details] [review]
possible fix

Does the attached patch help?
Comment 27 Kristian Klausen 2013-07-12 10:38:38 UTC
(In reply to comment #26)
> Created attachment 82347 [details] [review] [review]
> possible fix
> 
> Does the attached patch help?

Have just tested, and it dont change anything.
I still also don't know what it have to do with backlight? The screen is completely turned off, if I use a flash light I can see the screen is 100% off.
Comment 28 Johan Brannlund 2013-07-13 04:33:19 UTC
These problems seem similar to the bug I reported: https://bugs.freedesktop.org/show_bug.cgi?id=42162 . One common thread is that many of the affected machines are HP laptops. Maybe the HP ACPI implementation does something funny?
Comment 29 ka.nick 2013-08-11 14:29:54 UTC
I've the same issue on my HP4545s laptop (A4-4300M CPU).
At boot time I get 
...
[drm:radeon_acpi_init] *ERROR* Cannot find a backlight controller
...
then the computer boots and works just fine (except the brightness control is @ /sys/class/backlight/radeon_bl0/brightness, commonly unrecognizable by the software) but after resuming I have totally black screen. I can still ssh to it: it resumes normally - the only thing that goes wrong is the screen remains off. (It goes off as soon as the resume process begins). Kernels 3.9.X still have the issue.
I'm not sure the absence of the ACPI-controllable brightness is relevant to the case.
Comment 30 Alex Deucher 2013-08-19 17:21:03 UTC
Created attachment 84275 [details] [review]
possible fix 1/2

Does this patch set fix the issue?
Comment 31 Alex Deucher 2013-08-19 17:21:41 UTC
Created attachment 84276 [details] [review]
possible fix 2/2

Please apply both patches in this set.
Comment 32 Joshua Roys 2013-08-19 23:07:40 UTC
(In reply to comment #31)
> Created attachment 84276 [details] [review] [review]
> possible fix 2/2
> 
> Please apply both patches in this set.

Unfortunately these patches do not help.
Comment 33 Jose P. 2013-09-12 06:29:42 UTC
Created attachment 85691 [details]
dmesg+Xorg.0.log

Same bug here...
HP laptop (dv6-6174la), dual GPU:
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6520G] [1002:9647] (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] [1002:6741] (prog-if 00 [VGA controller])
Linux hostname 3.11.0-7-generic #13-Ubuntu SMP Tue Sep 10 20:55:38 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

workaround: use an external monitor (HDMI and VGA worked, with some problems though, but that is unrelated [you can see some warning and backtraces] and didn't happen before)

attached: whole dmesg, Xorg.0.log files after two consecutive suspend/resume cycles plus some testing with external monitors, and .diff files (from other session) showing messages logged only after suspend to RAM.
Comment 34 Hardening 2013-09-14 20:52:40 UTC
I have the exact same problem here but with a radeon HD 7310. I can try patches.
Comment 35 Hardening 2013-09-14 20:56:12 UTC
Sorry, I forgot to precise it was with kernel 3.11 and dpm activated.
Comment 36 Jose P. 2013-09-14 21:00:36 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > Created attachment 84276 [details] [review] [review] [review]
> > possible fix 2/2
> > 
> > Please apply both patches in this set.
> 
> Unfortunately these patches do not help.

same for me, the patches didn't work.
Comment 37 Jose P. 2013-09-17 23:24:36 UTC
Created attachment 86031 [details]
dmesg, xorg

I installed 3.12-rc1 from http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.12-rc1-saucy/ , it didn't help :(
Attached are the logs from dmesg (before and after running pm-suspend) and Xorg.0.log (there were no messages after resuming from suspend)
Comment 38 Vladimir Mityukov 2013-09-27 09:18:36 UTC
I'm not sure if I have the same issue. In particular, I could not find this error in my dmesg:
..
[drm:radeon_acpi_init] *ERROR* Cannot find a backlight controller
..

But I do have the issue that my laptop does not wake up fully (the screen is black).

There is some noise starts in the notebook and led indicators start blinking, but the screen does not turn ON.

I know, there are many possible reasons, but it worked with Catalyst, so, I think it has to be connected to video driver (dri, kms, xf86-video-ati, whatever..).

$ lspci | grep VGA
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6520G]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]

$ uname -a
Linux pilat-book 3.11.1-2-ARCH #1 SMP PREEMPT Sun Sep 22 19:45:00 CEST 2013 x86_64 GNU/Linux

I use radeon.dpm=1 in the kernel options;


Here's the bug-report to Archlinux tracker, but they suggested to file the bug here:
https://bugs.archlinux.org/task/37078
Comment 39 Jared Freeman 2013-10-24 04:10:48 UTC
Same issue with me.  I have an HP with an A8-3550MX (6620G graphics).  This issue as plagued me (and I am sure others) for quite some time.  I have pretty much relegated myself to using the fglrx binary blob.
Comment 40 Kristian Klausen 2013-10-27 20:07:43 UTC
Any process? This is the most annoying thing about using Linux..
Comment 41 bip91 2013-10-27 20:16:04 UTC
Same issue for my A8-450M laptop with Integrated or Discrete GPU set.
I made some tests from kernel 3.8.0 to 3.12-RC6 on Ubuntu.
I got same result with other distro like ArchLinux or Fedora.

# lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 15h (Models 10h-1
fh) Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinit
y [Radeon HD 7640G]

Some other tests on my main kernel 3.11.6 (Ubuntu PPA)
(CPU and GPU firmware has been updated to latest version)
 
 - After suspend and resume, with ssh I can check brightness control on /sys/class/blacklight/radeon_bl0/brightness and change the value but nothing change on screen (always black screen)
 - no syslog entry give information on the problem
 - no more information with drm.debug on kernel     
 - fglrx doesn't have the same problem, suspend and resume work fine
   (but fglrx don't allow to change brightness). 

So, this concern seems to come from the drm driver and not from kernel or acpi,
but I don't have enough knowledge to go further to identify the root cause in xorg
Comment 42 Jose P. 2013-11-19 04:53:40 UTC
I'm using kernel 3.13-rc0 from: http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-next/2013-11-14-trusty/
3.12.0-996-generic #201311140516
and this is still happening...
I guess I'll have to go back to fglrx.
I wished I could help devs, but this is driving me crazy. Not being able to resume from suspend is why I wanted to test the open-source driver in the first place...
Comment 43 Adam Pigg 2013-12-28 11:14:50 UTC
Same problem here running on a HP Laptop Pavillion G7 with AMD A6-3400M CPU/GPU.

Currently running 3.12.5 kernel from openSuse Tumbleweed, though ive had this problem for ages.
Comment 44 Helge Bahmann 2014-01-19 10:20:21 UTC
This bug is really old and really annoying as it makes the laptops unusable for suspend -- what kind of traces would be required to understand the core of the problem, from what I can tell the display engine is in a severely hosed state, but I lack documentation to understand what is wrong.

Does setting out a bounty for this bug help? I'm willing to immediately cash in at $300.
Comment 45 Jose P. 2014-03-29 22:31:23 UTC
Any updates one this?
Kernel 3.14-rc6 + mesa 10.2-git (I tested it a couple weeks ago), still the same.
Any clues on where to look for bugs and/or how to debug?
Comment 46 Kristian Klausen 2014-03-30 22:09:43 UTC
(In reply to comment #45)
> Any updates one this?
> Kernel 3.14-rc6 + mesa 10.2-git (I tested it a couple weeks ago), still the
> same.
> Any clues on where to look for bugs and/or how to debug?

I also want a status on this. This is 1% to make Linux 100% perfect.
Comment 47 austin.hoppe7 2014-03-31 02:18:36 UTC
Kernel 3.14-rc8 (with PRIME) + mesa 10.2-git (radeon driver with kms and dpm)
Still the same issue, suspend + resume works fine but the laptop's screen does not turn back on. Using an external monitor confirms that the system itself is functional after resume. When running fglrx, there is no issue.
HP dv6z 6100 CTO QE (ca. 2011). CPU: AMD 18-3510mx, iGPU: Radeon HD 6620g, dGPU: Radeon HD 6750m.
Comment 48 Swoorup 2014-04-02 04:18:22 UTC
I got the same issue here. 

After I suspend my machine and try to wake up, the screen does not display anything else. And I'd have to blindly switch to tty terminal and type reboot.

Info:
Linux 3.13.8-1 (Arch linux)
Mesa - 10.1.0

Radeon 7520G
Comment 49 n0000b 2014-04-03 02:18:34 UTC
I have a similar issue with a samsumg series 3 laptop with "VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external monitor show the system is still responsive.

BUT I can make the screen turn on after suspend with the next command:
sudo pm-suspend --quirk-test --quirk-s3-bios

so if you can try and this work maybe we can kick this issue.
Comment 50 Helge Bahmann 2014-04-03 06:16:27 UTC
(In reply to comment #49)
> I have a similar issue with a samsumg series 3 laptop with "VGA compatible
> controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD
> 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc.
> [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external
> monitor show the system is still responsive.
> 
> BUT I can make the screen turn on after suspend with the next command:
> sudo pm-suspend --quirk-test --quirk-s3-bios

whoa, that worked as well for me! I'll try to dissect unless someone else jumps to it, and then make good on my promise above :)
Comment 51 n0000b 2014-04-03 07:44:39 UTC
maybe the same issue? https://bugs.freedesktop.org/show_bug.cgi?id=42960

also, isn't pm-utils somehow deprecated?
if we add the parameter in /etc/pm/config.d/ will the command "systemctl suspend" be able to turn on the screen? i think that "systemctl suspend" doesn't rely on pm-utils
Comment 52 Kristian Klausen 2014-04-03 09:04:39 UTC
(In reply to comment #51)
> maybe the same issue? https://bugs.freedesktop.org/show_bug.cgi?id=42960
> 
> also, isn't pm-utils somehow deprecated?
> if we add the parameter in /etc/pm/config.d/ will the command "systemctl
> suspend" be able to turn on the screen? i think that "systemctl suspend"
> doesn't rely on pm-utils

I looked in the pm-utils sourcecode, and adding acpi_sleep=s3_bios to the cmdline fix it for me.

You can read a little about it here: https://www.kernel.org/doc/Documentation/power/video.txt
Comment 53 Joshua Roys 2014-04-03 11:03:35 UTC
Seems to work for me too.  I'm sure one of Alex's patches helped out too, so thank you Alex.

I do get this on resume, but that's probably for another bug:
[  117.375124] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 5secs aborting
[  117.375127] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing E442 (len 2585, WS 4, PS 4) @ 0xEB2C
[  117.436913] [drm:radeon_dp_link_train_cr] *ERROR* clock recovery reached max voltage
[  117.436914] [drm:radeon_dp_link_train_cr] *ERROR* clock recovery failed
Comment 54 austin.hoppe7 2014-04-03 17:02:27 UTC
Awesome. To spell it out a little more explicitly, here is what I did (Arch x86_64 3.14-mainline) to have this apparently accomplished automatically from now on:

sudo su

echo 'ADD_PARAMETERS="--quirk-test --quirk-s3-bios"' >> /etc/pm/config.d/00-fix_dv6z_suspend_screen

pm-suspend --quirk-test --quirk-s3-bios --store-quirks-as-lkw

Which should save the quirks, perhaps with some redundancy. Checking the contents of the (new)

/etc/pm/last_known_working.quirkdb

file should show the matches made against your particular system, especially e.g. hardware and firmware details. I guess these could be patched into (for my HP at least)

/usr/lib/pm-utils/video-quirks/20-video-quirk-pm-hp.quirkdb

with some of the returned information, given that this file is supposed to have a fairly up-to-date {white,black,broken}-list.

Obviously follow this only at your own risk, etc. I have no idea how this would work when it comes to fglrx, or even how stable it is against kernel/pm/upower/whatever updates. Here are some more good references for information:

https://trisquel.info/en/wiki/troubleshooting-suspendhibernate

https://wiki.archlinux.org/index.php/pm-utils
Comment 55 Jose P. 2014-04-03 17:58:08 UTC
(In reply to comment #49)
> I have a similar issue with a samsumg series 3 laptop with "VGA compatible
> controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD
> 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc.
> [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external
> monitor show the system is still responsive.
> 
> BUT I can make the screen turn on after suspend with the next command:
> sudo pm-suspend --quirk-test --quirk-s3-bios
> 
> so if you can try and this work maybe we can kick this issue.

GREAT, it works for me, thank you very much!
I did try pm-suspend with different flags some months ago.. I guess my testing was too conservative :(
@ klausenbusk@hotmail.com and austin.hoppe7@live.com , thank you too! and once again, thanks AMD devs :)
Comment 56 Kristian Klausen 2014-04-03 18:12:08 UTC
(In reply to comment #54)
> Awesome. To spell it out a little more explicitly, here is what I did (Arch
> x86_64 3.14-mainline) to have this apparently accomplished automatically
> from now on:
> 
> sudo su
> 
> echo 'ADD_PARAMETERS="--quirk-test --quirk-s3-bios"' >>
> /etc/pm/config.d/00-fix_dv6z_suspend_screen
> 
> pm-suspend --quirk-test --quirk-s3-bios --store-quirks-as-lkw
> 
> Which should save the quirks, perhaps with some redundancy. Checking the
> contents of the (new)
> 
> /etc/pm/last_known_working.quirkdb
> 
> file should show the matches made against your particular system, especially
> e.g. hardware and firmware details. I guess these could be patched into (for
> my HP at least)
> 
> /usr/lib/pm-utils/video-quirks/20-video-quirk-pm-hp.quirkdb
> 
> with some of the returned information, given that this file is supposed to
> have a fairly up-to-date {white,black,broken}-list.
> 
> Obviously follow this only at your own risk, etc. I have no idea how this
> would work when it comes to fglrx, or even how stable it is against
> kernel/pm/upower/whatever updates. Here are some more good references for
> information:
> 
> https://trisquel.info/en/wiki/troubleshooting-suspendhibernate
> 
> https://wiki.archlinux.org/index.php/pm-utils

Hmm. I just did:
sudo nano /etc/default/grub
found GRUB_CMDLINE_LINUX_DEFAULT and added acpi_sleep=s3_bios just before quiet
ctrl+o and ctrl+x
sudo grub-mkconfig -o /boot/grub/grub.cfg
Comment 57 Jose P. 2014-04-03 19:45:59 UTC
(In reply to comment #55)
> (In reply to comment #49)
> > I have a similar issue with a samsumg series 3 laptop with "VGA compatible
> > controller: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek [Radeon HD
> > 6620G]" and "VGA compatible controller: Advanced Micro Devices, Inc.
> > [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]". after resume an external
> > monitor show the system is still responsive.
> > 
> > BUT I can make the screen turn on after suspend with the next command:
> > sudo pm-suspend --quirk-test --quirk-s3-bios
> > 
> > so if you can try and this work maybe we can kick this issue.
> 
> GREAT, it works for me, thank you very much!
> I did try pm-suspend with different flags some months ago.. I guess my
> testing was too conservative :(
> @ klausenbusk@hotmail.com and austin.hoppe7@live.com , thank you too! and
> once again, thanks AMD devs :)

I see now... I DID test the '--quirk-s3-bios' flag, but I need '--quirk-test', which is not documented in the manpage...

from pm-utils-1.4.1/README.debugging:
"* To override the usual quirk filtering (for kernel modesetting, binary drivers, and exotic hardware), pass --quirk-test along with any other quirks you want to try.  This may make your system crash in new and exciting ways by conflicting with the kernel when suspending or resuming, but is very useful for debugging.  You have been warned."
Oh, well, I'm happy that someone found a solution and shared it with us all :D
Comment 58 Alex Deucher 2014-04-03 20:01:06 UTC

*** This bug has been marked as a duplicate of bug 42960 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.