Bug 4457 - xf86driproto references dri_interface.h, but mesa doesn't install it
Summary: xf86driproto references dri_interface.h, but mesa doesn't install it
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Other (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-14 20:39 UTC by Joshua Baergen
Modified: 2009-08-24 12:23 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Description Joshua Baergen 2005-09-14 20:39:42 UTC
XF86DRI proto's xf86dri.h references GL/internal/dri_interface.h .  This file is
missing.  The only file that is provided is internal/glcore.h, but
monolithic/xc/extras/Mesa/include/GL/internal/ (where glcore.h) holds sarea.h
and dri_interface.h

I came across this while trying to build the via driver (modular).
Comment 1 Donnie Berkholz 2005-10-16 00:57:52 UTC
This should definitely get looked at for 6.4, one way or the other. Reassigning
to mesa.
Comment 2 Donnie Berkholz 2005-10-16 00:58:41 UTC
Could use a decision for 6.4.
Comment 3 Ian Romanick 2005-10-16 20:11:11 UTC
*All* DRI drivers and libGL will need dri_interface.h.  Afterall, it defines the
interface between them!  I believe that it was intended to be included, but was
accidentally omitted.

I think Brian is away on vacation for a few days, so I'll try to resolve this on
Monday.
Comment 4 Adam Jackson 2005-10-17 20:45:42 UTC
dri_interface.h is going into driproto, because it'll be shared API once we fix
libglx to load DRI drivers.  it should come out of Mesa at some point, but i'm
not particularly concerned about that for now.
Comment 5 Adam Jackson 2005-10-17 23:05:45 UTC
fixed in head, huzzahs.
Comment 6 Adam Jackson 2009-08-24 12:23:25 UTC
Mass version move, cvs -> git


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.