Bug 45852 - Broken dependency resolution when installing/removing
Summary: Broken dependency resolution when installing/removing
Status: RESOLVED NOTABUG
Alias: None
Product: PackageKit
Classification: Unclassified
Component: backend-zypp (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Scott Reeves
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-09 11:50 UTC by Aleksey Danilov
Modified: 2018-08-21 15:52 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksey Danilov 2012-02-09 11:50:51 UTC
The first time I tried to install something via Apper/packagekit/zypper, I got list of "required" packages which were obviously unrelated to the one I wanted to pull. I tried issuing installation of different applications (Kaffeine, KSystemLog, Kate), and in all cases the same list of (unneeded) additional packages appeared:
- gstreamer-0_10-fluendo-mp3;
- parallel-printer-support;
- AdobeICCProfiles;
- bundle-lang-gnome-extras-en;
- oxygen-icon-theme-large;
- poppler-data;
- patterns-openSUSE-kde4_pure.

Moreover, I tried to first install Kaffeine via YaST (BTW, no additional packages were required) and then remove it with Apper. To my surpise, during removal I got gstreamer-0_10-fluendo-mp3 license agreement requesting confirmation! 

Although this list does not show up when updating, I instead get "The package that is being modified was not found..." error with no details and no visible consequences (all packages successfully installed according to the zypper's log). Not sure whether it is the same or separate issue.

I first filed bug report on Apper but was eventually referred here.
Comment 1 bugspam 2012-09-26 23:36:21 UTC
I have the same problem as Aleksey. I thought it was an issue with Apper, as only Apper seems to do it for me. Zypper seems unaffected, as does YaST for me. In my case, it wanted to pull down a different set of unnecessary packages (including everything matching the pattern xorg-x11-driver-*, e.g. every video driver for every card in existence). I've added locks on all the ones it wants, though marking packages as taboo in YaST did nothing to dissuade packagekit. 

I'm using OpenSUSE 12.2 x64 with KDE 4.9.1.
Comment 2 Richard Hughes 2018-08-21 15:52:15 UTC
We moved the upstream bugtracker to GitHub a long time ago. If this issue still affects you please re-create the issue here: https://github.com/hughsie/PackageKit/issues
 
Sorry for the impersonal message, and fingers crossed your issue no longer happens. Thanks.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.